aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.python.mk
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-02-22 15:44:48 +0800
committerwen <wen@FreeBSD.org>2011-02-22 15:44:48 +0800
commitbea856ad937f4b110473c7ff5b43a1cd7488ff9f (patch)
tree07dd50da266070fe8ba371bbef0c72635d3bc725 /Mk/bsd.python.mk
parentfe4dcf6dd74aed53644b27a055a367bbb58230e3 (diff)
downloadfreebsd-ports-gnome-bea856ad937f4b110473c7ff5b43a1cd7488ff9f.tar.gz
freebsd-ports-gnome-bea856ad937f4b110473c7ff5b43a1cd7488ff9f.tar.zst
freebsd-ports-gnome-bea856ad937f4b110473c7ff5b43a1cd7488ff9f.zip
- Update to 3.2.0 and complete repocopy
PR: ports/153829 Submitted by: Wen Heping (myself) Reviewed by: miwi@
Diffstat (limited to 'Mk/bsd.python.mk')
-rw-r--r--Mk/bsd.python.mk13
1 files changed, 11 insertions, 2 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 3caafe7cbc81..2c6e2c15ece6 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -214,7 +214,7 @@ Python_Include_MAINTAINER= python@FreeBSD.org
#
_PYTHON_PORTBRANCH= 2.6
-_PYTHON_ALLBRANCHES= 2.6 2.5 2.4 2.7 3.1 # preferred first
+_PYTHON_ALLBRANCHES= 2.6 2.5 2.4 2.7 3.1 3.2# preferred first
_ZOPE_PORTBRANCH= 2.7
_ZOPE_ALLBRANCHES= 2.7 2.8 2.9 2.10 3.2
@@ -369,8 +369,16 @@ PYTHON_PORTVERSION= ${PYTHON_DEFAULT_PORTVERSION}
# Propagate the chosen python version to submakes.
.MAKEFLAGS: PYTHON_VERSION=python${_PYTHON_VERSION}
+# Python-3.2
+.if ${PYTHON_VERSION} == "python3.2"
+PYTHON_PORTVERSION?=3.2
+PYTHON_PORTSDIR= ${PORTSDIR}/lang/python32
+PYTHON_REL= 320
+PYTHON_SUFFIX= 32
+PYTHON_VER= 3.2
+
# Python-3.1
-.if ${PYTHON_VERSION} == "python3.1"
+.elif ${PYTHON_VERSION} == "python3.1"
PYTHON_PORTVERSION?=3.1.3
PYTHON_PORTSDIR= ${PORTSDIR}/lang/python31
PYTHON_REL= 313
@@ -428,6 +436,7 @@ check-makevars::
@${ECHO} " python2.6 (default)"
@${ECHO} " python2.7"
@${ECHO} " python3.1"
+ @${ECHO} " python3.2"
@${FALSE}
.endif