aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.python.mk
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-03-05 08:39:33 +0800
committerbf <bf@FreeBSD.org>2011-03-05 08:39:33 +0800
commit14058d87da98250873bced00aba98ed35b4bbd0b (patch)
tree2d0de34657b8a8a209ab5ee08a97e4684a4adff8 /Mk/bsd.python.mk
parent15690e57bbd9da788d15a570553bf60444ce3343 (diff)
downloadfreebsd-ports-gnome-14058d87da98250873bced00aba98ed35b4bbd0b.tar.gz
freebsd-ports-gnome-14058d87da98250873bced00aba98ed35b4bbd0b.tar.zst
freebsd-ports-gnome-14058d87da98250873bced00aba98ed35b4bbd0b.zip
Tell ports that USE_PYDISTUTILS to link shared objects
with the same compiler used to build them. While here, fix a typo. PR: 154742 Approved by: miwi
Diffstat (limited to 'Mk/bsd.python.mk')
-rw-r--r--Mk/bsd.python.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 0852895863ff..fb27759e880e 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -516,7 +516,7 @@ PLIST_FILES+= ${PYDISTUTILS_EGGINFODIR:S;${PREFIX}/;;}/${egg}
. endfor
.endif
-# Fix for programs that build python from a GNU auto* enviornment
+# Fix for programs that build python from a GNU auto* environment
CONFIGURE_ENV+= PYTHON="${PYTHON_CMD}"
# Zope-related variables
@@ -678,6 +678,9 @@ PYDISTUTILS_BUILD_TARGET?= build
PYDISTUTILS_INSTALL_TARGET?= install
.if defined(USE_PYDISTUTILS)
+LDSHARED?= ${CC} -shared
+MAKE_ENV+= LDSHARED="${LDSHARED}"
+
.if !target(do-configure) && !defined(HAS_CONFIGURE) && !defined(GNU_CONFIGURE)
do-configure:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} ${PYDISTUTILS_CONFIGURE_TARGET} ${PYDISTUTILS_CONFIGUREARGS})