aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.python.mk
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-03-05 00:08:23 +0800
committermiwi <miwi@FreeBSD.org>2011-03-05 00:08:23 +0800
commit35ded24c76346c52b20de58cf5bb75bb92f10609 (patch)
treea9d9493e5041df0d072503985b2bd35ba3abd8e8 /Mk/bsd.python.mk
parentc4991975ff7501264a1e2d821d65c9d43b21828b (diff)
downloadfreebsd-ports-gnome-35ded24c76346c52b20de58cf5bb75bb92f10609.tar.gz
freebsd-ports-gnome-35ded24c76346c52b20de58cf5bb75bb92f10609.tar.zst
freebsd-ports-gnome-35ded24c76346c52b20de58cf5bb75bb92f10609.zip
- Make Python 2.7.1 the default Python version
Tested by: 2x pointyhat runs
Diffstat (limited to 'Mk/bsd.python.mk')
-rw-r--r--Mk/bsd.python.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index d653392e53f7..c6df15a4c55e 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -83,9 +83,9 @@ Python_Include_MAINTAINER= python@FreeBSD.org
#
# PYTHON_DEFAULT_VERSION
# - Version of the default python binary in your ${PATH}, in
-# the format "python2.6". Set this in your /etc/make.conf
+# the format "python2.7". Set this in your /etc/make.conf
# in case you want to use an older version as a default.
-# default: python2.6
+# default: python2.7
#
# PYTHON_WRKSRC - The ${WRKSRC} for your python version. Needed for
# extensions like Tkinter, py-gdbm and py-expat, which
@@ -201,8 +201,8 @@ Python_Include_MAINTAINER= python@FreeBSD.org
# specific version of zope.
#
-_PYTHON_PORTBRANCH= 2.6
-_PYTHON_ALLBRANCHES= 2.6 2.5 2.4 2.7 3.1 3.2# preferred first
+_PYTHON_PORTBRANCH= 2.7
+_PYTHON_ALLBRANCHES= 2.7 2.6 2.5 2.7 3.1 3.2# preferred first
_ZOPE_PORTBRANCH= 2.7
_ZOPE_ALLBRANCHES= 2.7 2.8 2.9 2.10 3.2
@@ -421,8 +421,8 @@ check-makevars::
@${ECHO} "Legal values are:"
@${ECHO} " python2.4"
@${ECHO} " python2.5"
- @${ECHO} " python2.6 (default)"
- @${ECHO} " python2.7"
+ @${ECHO} " python2.6"
+ @${ECHO} " python2.7 (default)"
@${ECHO} " python3.1"
@${ECHO} " python3.2"
@${FALSE}