aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.python.mk
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-03-10 00:26:10 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-03-10 00:26:10 +0800
commit3f388703cd03f63fa7a1c3667f53abfb6be1d1ee (patch)
treebd1bfca6a4d1b3918c3a1285d3fef52685a9e16f /Mk/bsd.python.mk
parenta0b4dedac253543caf552cc191ab43d844a291e0 (diff)
downloadfreebsd-ports-gnome-3f388703cd03f63fa7a1c3667f53abfb6be1d1ee.tar.gz
freebsd-ports-gnome-3f388703cd03f63fa7a1c3667f53abfb6be1d1ee.tar.zst
freebsd-ports-gnome-3f388703cd03f63fa7a1c3667f53abfb6be1d1ee.zip
- Fix following error message when "make update" with python{32,33} as default python interpreter
make[1]: "/usr/ports/Mk/bsd.python.mk" line 343: Malformed conditional (exists(${PYTHON_CMD}-config) && ${PORTNAME} != python33) make[1]: Fatal errors encountered -- cannot continuemake: "/usr/ports/Mk/bsd.port.subdir.mk" line 123: warning: "make -V PYTHONBASE USE_PYTHON=1 -f /usr/ports/Mk/bsd.port.mk" returned non-zero status Approved by: antoine (portmgr)
Diffstat (limited to 'Mk/bsd.python.mk')
-rw-r--r--Mk/bsd.python.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 44c344feeca5..e1abfa107d2c 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -340,7 +340,7 @@ PYTHON_PORTSDIR= ${PORTSDIR}/lang/python33
PYTHON_REL= 334
PYTHON_SUFFIX= 33
PYTHON_VER= 3.3
-.if exists(${PYTHON_CMD}-config) && ${PORTNAME} != python33
+.if exists(${PYTHON_CMD}-config) && defined(PORTNAME) && ${PORTNAME} != python33
PYTHON_ABIVER!= ${PYTHON_CMD}-config --abiflags
.endif
@@ -351,7 +351,7 @@ PYTHON_PORTSDIR= ${PORTSDIR}/lang/python32
PYTHON_REL= 325
PYTHON_SUFFIX= 32
PYTHON_VER= 3.2
-.if exists(${PYTHON_CMD}-config) && ${PORTNAME} != python32
+.if exists(${PYTHON_CMD}-config) && defined(PORTNAME) && ${PORTNAME} != python32
PYTHON_ABIVER!= ${PYTHON_CMD}-config --abiflags
.endif