aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.python.mk
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2001-04-04 20:32:45 +0800
committertg <tg@FreeBSD.org>2001-04-04 20:32:45 +0800
commit22d7a4bb23dfa39dd771b8d235699bd214a756a1 (patch)
tree30dc335601cf0a2c6b6c5f3114f88dceb736994f /Mk/bsd.python.mk
parent0a9c82d0f2ae86fe48c76c25ac6f54d66c0a4f48 (diff)
downloadfreebsd-ports-gnome-22d7a4bb23dfa39dd771b8d235699bd214a756a1.tar.gz
freebsd-ports-gnome-22d7a4bb23dfa39dd771b8d235699bd214a756a1.tar.zst
freebsd-ports-gnome-22d7a4bb23dfa39dd771b8d235699bd214a756a1.zip
I don't know offhand how to delay defining PYTHON_PLATFORM until
the dependencies are evaluated and $PYTHON_CMD will surely exist, so I fake it with the help of expr(1), $OPSYS and $OSREL. PR: 26318
Diffstat (limited to 'Mk/bsd.python.mk')
-rw-r--r--Mk/bsd.python.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 32b93e7cf473..54f71f25916c 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -37,6 +37,9 @@ Python_Include_MAINTAINER= tg@FreeBSD.org
# default: py${PYTHON_SUFFIX}-
#
# PYTHON_PLATFORM: Python's idea of the OS release.
+# XXX This is faked with ${OPSYS} and ${OSREL} until I
+# find out how to delay defining a variable until after
+# a certain target has been built.
#
# PYTHON_PORTSDIR: The source of your binary's port. Needed for the
# RUN_DEPENDS.
@@ -128,7 +131,7 @@ PYTHON_CMD= ${LOCALBASE}/bin/${PYTHON_VERSION}
PYTHON_INCLUDEDIR= ${LOCALBASE}/include/${PYTHON_VERSION}
PYTHON_LIBDIR= ${LOCALBASE}/lib/${PYTHON_VERSION}
PYTHON_PKGNAMEPREFIX= py${PYTHON_SUFFIX}-
-PYTHON_PLATFORM!= ${PYTHON_CMD} -c 'import sys; print sys.platform'
+PYTHON_PLATFORM!= expr ${OPSYS:L}${OSREL} : '\(.*\)\.'
PYTHON_SITELIBDIR= ${PYTHON_LIBDIR}/site-packages
# dependencies