aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.python.mk
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2003-11-05 02:07:03 +0800
committerperky <perky@FreeBSD.org>2003-11-05 02:07:03 +0800
commit1a618a8c798eb23acfdc5d89dd9dad17bc29ccec (patch)
tree80fabb6365508feb5a1a7daf4df0824538c48f2a /Mk/bsd.python.mk
parente19db124245172e87f053364c8d43d707768381a (diff)
downloadfreebsd-ports-gnome-1a618a8c798eb23acfdc5d89dd9dad17bc29ccec.tar.gz
freebsd-ports-gnome-1a618a8c798eb23acfdc5d89dd9dad17bc29ccec.tar.zst
freebsd-ports-gnome-1a618a8c798eb23acfdc5d89dd9dad17bc29ccec.zip
Add dependency line for pyexpat as ${PYEXPAT} to provide adaptive
dependency for both of pre-2.3.2_2 and after-.
Diffstat (limited to 'Mk/bsd.python.mk')
-rw-r--r--Mk/bsd.python.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index a5be4451278e..f01e5e15403f 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -312,6 +312,12 @@ PYNUMERIC= ${PYTHON_SITELIBDIR}/Numeric/Numeric.py:${PORTSDIR}/math/py-numeric
PYXML= ${PYTHON_SITELIBDIR}/_xmlplus/__init__.py:${PORTSDIR}/textproc/py-xml
.endif
+.if defined(PYTHON_REL) && ${PYTHON_REL} < 232
+PYEXPAT= ${PYTHON_SITELIBDIR}/pyexpat.so:${PORTSDIR}/textproc/py-expat
+.else
+PYEXPAT= ${PYTHON_LIBDIR}/lib-dynload/pyexpat.so:${PYTHON_PORTSDIR}
+.endif
+
# dependencies
PYTHON_NO_DEPENDS?= NO