aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.python.mk
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-02-25 17:46:39 +0800
committermiwi <miwi@FreeBSD.org>2011-02-25 17:46:39 +0800
commit84b2efc9bcff2ad1347e4e6cc0926b1887499149 (patch)
treea8c38f33bbc05435b12d8a54e6ccd1743155830e /Mk/bsd.python.mk
parentecb613aff5556cd18082cdbf9ff071c3ab3659c5 (diff)
downloadfreebsd-ports-gnome-84b2efc9bcff2ad1347e4e6cc0926b1887499149.tar.gz
freebsd-ports-gnome-84b2efc9bcff2ad1347e4e6cc0926b1887499149.tar.zst
freebsd-ports-gnome-84b2efc9bcff2ad1347e4e6cc0926b1887499149.zip
- Part 1 of python24 removal
- Clean up bsd.python.mk (remove PYWSGIREF, PYHASHLIB, PYCTYPES and PYEXPAT) all these is now part of python since python25 Remove: textproc/py-expat devel/py-ctypes security/py-hashlib www/py-wsgiref
Diffstat (limited to 'Mk/bsd.python.mk')
-rw-r--r--Mk/bsd.python.mk36
1 files changed, 0 insertions, 36 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 2c6e2c15ece6..d653392e53f7 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -110,18 +110,6 @@ Python_Include_MAINTAINER= python@FreeBSD.org
# PYXML - Dependency line for the XML extension. As of Python-2.0,
# this extension is in the base distribution.
#
-# PYEXPAT - Dependency line for the Expat XML Parser. As of Python-2.3.2,
-# this module is in the base distribution.
-#
-# PYCTYPES - Dependency line for the ctypes package. As of Python-2.5,
-# this module is in the base distribution.
-#
-# PYHASHLIB - Dependency line for the hashlib package. As of Python-2.5,
-# this module is in the base distribution.
-#
-# PYWSGIREF - Dependency line for the wsgiref package. As of Python-2.5,
-# this module is in the base distribution.
-#
# USE_PYTHON_PREFIX - Says that the port installs in ${PYTHONBASE}.
#
# USE_PYDISTUTILS - Use distutils as do-configure, do-build and do-install
@@ -569,30 +557,6 @@ PYNUMERIC= ${PYTHON_SITELIBDIR}/Numeric/Numeric.py:${PORTSDIR}/math/py-numeric
PYNUMPY= ${PYTHON_SITELIBDIR}/numpy/core/numeric.py:${PORTSDIR}/math/py-numpy
PYXML= ${PYTHON_SITELIBDIR}/_xmlplus/__init__.py:${PORTSDIR}/textproc/py-xml
-.if defined(PYTHON_REL) && ${PYTHON_REL} < 232
-PYEXPAT= ${PYTHON_SITELIBDIR}/pyexpat.so:${PORTSDIR}/textproc/py-expat
-.else
-PYEXPAT= ${PYTHON_LIBDIR}/lib-dynload/pyexpat.so:${PYTHON_PORTSDIR}
-.endif
-
-.if defined(PYTHON_REL) && ${PYTHON_REL} < 250
-PYCTYPES= ${PYTHON_SITELIBDIR}/ctypes/__init__.py:${PORTSDIR}/devel/py-ctypes
-.else
-PYCTYPES= ${PYTHON_LIBDIR}/ctypes/__init__.py:${PYTHON_PORTSDIR}
-.endif
-
-.if defined(PYTHON_REL) && ${PYTHON_REL} < 250
-PYHASHLIB= ${PYTHON_SITELIBDIR}/hashlib.py:${PORTSDIR}/security/py-hashlib
-.else
-PYHASHLIB= ${PYTHON_LIBDIR}/hashlib.py:${PYTHON_PORTSDIR}
-.endif
-
-.if defined(PYTHON_REL) && ${PYTHON_REL} < 250
-PYWSGIREF= ${PYTHON_SITELIBDIR}/wsgiref/__init__.py:${PORTSDIR}/www/py-wsgiref
-.else
-PYWSGIREF= ${PYTHON_LIBDIR}/wsgiref/__init__.py:${PYTHON_PORTSIDR}
-.endif
-
# dependencies
PYTHON_NO_DEPENDS?= NO