aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.qt.mk
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2012-06-02 08:08:27 +0800
committerrakuco <rakuco@FreeBSD.org>2012-06-02 08:08:27 +0800
commitb56c81cff2f9aaf42727cee6179be4af87ec0d72 (patch)
tree561081ac65caad76e531cf75ddbaee1fd87d3c54 /Mk/bsd.qt.mk
parentb0f7cb0df680686966bc9d0506ce43991d41c574 (diff)
downloadfreebsd-ports-gnome-b56c81cff2f9aaf42727cee6179be4af87ec0d72.tar.gz
freebsd-ports-gnome-b56c81cff2f9aaf42727cee6179be4af87ec0d72.tar.zst
freebsd-ports-gnome-b56c81cff2f9aaf42727cee6179be4af87ec0d72.zip
The KDE on FreeBSD team is happy to update Qt to its 4.8.2 release.
The upstream changelog can be seen in <https://qt.gitorious.org/qt/qt/blobs/4.8/dist/changes-4.8.2>. Relevant changes include a few patches having been integrated upstream and thus removed from the ports tree and some improved work on USE_QT4 in bsd.qt.mk.
Diffstat (limited to 'Mk/bsd.qt.mk')
-rw-r--r--Mk/bsd.qt.mk20
1 files changed, 10 insertions, 10 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index 01821122cc28..63566e8344cd 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -146,9 +146,9 @@ QTCGFLIBS?=
#
# QT4 version
#
-QT4_VERSION?= 4.8.1
+QT4_VERSION?= 4.8.2
-_QT_COMPONENTS_ALL= accessible assistant assistant-adp assistantclient \
+_USE_QT4_ALL= accessible assistant assistant-adp assistantclient \
clucene codecs-cn codecs-jp codecs-kr codecs-tw corelib \
dbus declarative demo designer doc \
graphicssystems-opengl gui help help-tools \
@@ -342,26 +342,26 @@ xmlpatterns-tool_DEPENDS= ${QT_PREFIX}/bin/xmlpatterns
.if defined(_POSTMKINCLUDED) && !defined(Qt_Post_Include)
Qt_Post_Include= bsd.qt.mk
-.for component in ${_QT_COMPONENTS_ALL}
+.for component in ${_USE_QT4_ALL}
${component}_BUILD_DEPENDS?= ${${component}_DEPENDS}:${PORTSDIR}/${${component}_PORT}
${component}_RUN_DEPENDS?= ${${component}_DEPENDS}:${PORTSDIR}/${${component}_PORT}
${component}_build_BUILD_DEPENDS?= ${${component}_BUILD_DEPENDS}
${component}_run_RUN_DEPENDS?= ${${component}_RUN_DEPENDS}
-_QT_COMPONENTS_ALL_SUFFIXED+= ${component} ${component}_build ${component}_run
+_USE_QT4_ALL_SUFFIXED+= ${component} ${component}_build ${component}_run
.endfor
-.if defined(USE_QT4)
-QT_COMPONENTS= ${USE_QT4}
-.endif
.if defined(QT_COMPONENTS)
-. for component in ${QT_COMPONENTS:O:u}
-. if ${_QT_COMPONENTS_ALL_SUFFIXED:M${component}}!= ""
+USE_QT4= ${QT_COMPONENTS}
+.endif
+.if defined(USE_QT4)
+. for component in ${USE_QT4:O:u}
+. if ${_USE_QT4_ALL_SUFFIXED:M${component}}!= ""
BUILD_DEPENDS+= ${${component}_BUILD_DEPENDS}
RUN_DEPENDS+= ${${component}_RUN_DEPENDS}
. else
-IGNORE= can't be installed: unknown Qt 4 component '${component}'
+IGNORE= can't be installed: unknown USE_QT4 component '${component}'
. endif
. endfor
.endif