aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.qt.mk
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2007-07-27 18:31:45 +0800
committerlofi <lofi@FreeBSD.org>2007-07-27 18:31:45 +0800
commit93acbfb76520d930e09acaa7483854a02549203e (patch)
tree9a8fb89fbe83cd844a572694dfe575185962713b /Mk/bsd.qt.mk
parentb9246e8925636d16f836a95298f9946036539a6d (diff)
downloadfreebsd-ports-gnome-93acbfb76520d930e09acaa7483854a02549203e.tar.gz
freebsd-ports-gnome-93acbfb76520d930e09acaa7483854a02549203e.tar.zst
freebsd-ports-gnome-93acbfb76520d930e09acaa7483854a02549203e.zip
The bug that makes gcc 3.4 choke on some amd64 inline assembler does not
only affect the Qt4 core ports but ports depending on them as well, so try a more sweeping approach for a workaround.
Diffstat (limited to 'Mk/bsd.qt.mk')
-rw-r--r--Mk/bsd.qt.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index 58a24f10708c..6e819a515386 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -45,8 +45,13 @@ UIC?= ${QT_PREFIX}/bin/uic-qt4
QMAKE?= ${QT_PREFIX}/bin/qmake-qt4
QMAKESPEC?= ${QT_PREFIX}/share/qt4/mkspecs/freebsd-g++
+.if ${OSVERSION} < 700042 && ${ARCH} == "amd64"
+QTCPPFLAGS?= -fno-gcse
+.else
QTCPPFLAGS?=
+.endif
QTCGFLIBS?=
+
.endif # !defined(_POSTMKINCLUDED) && !defined(Qt_Pre_Include)
QT4_VERSION?= 4.3.0