aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.qt.mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-10-15 00:49:35 +0800
committerbapt <bapt@FreeBSD.org>2015-10-15 00:49:35 +0800
commitfe149e93dc167d1fb2cfd567cb6bb47b29d7616e (patch)
tree253c001da30db94087f88bf237955915bfb0f012 /Mk/bsd.qt.mk
parent272e7189dabf5351b4cf86d3b7ab8ba8c2c22032 (diff)
downloadfreebsd-ports-gnome-fe149e93dc167d1fb2cfd567cb6bb47b29d7616e.tar.gz
freebsd-ports-gnome-fe149e93dc167d1fb2cfd567cb6bb47b29d7616e.tar.zst
freebsd-ports-gnome-fe149e93dc167d1fb2cfd567cb6bb47b29d7616e.zip
Drop the necessity to add ${PORTSDIR} to dependency line
Modify make describe to automatically prepend ${PORTSDIR} if the path for the port is not absolute Checked with poudriere, portmaster, portupgrade PR: 203685 Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D3866
Diffstat (limited to 'Mk/bsd.qt.mk')
-rw-r--r--Mk/bsd.qt.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index 8771b659623e..e0fa9e6b1777 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -542,8 +542,8 @@ xmlpatterns-tool_PATH= ${QT_BINDIR}/xmlpatterns
_USE_QT_ALL+= ${_USE_QT${_QT_VERSION:R:R}_ONLY}
.for comp in ${_USE_QT_ALL}
-${comp}_BUILD_DEPENDS?= ${${comp}_PATH}:${PORTSDIR}/${${comp}_PORT}
-${comp}_RUN_DEPENDS?= ${${comp}_PATH}:${PORTSDIR}/${${comp}_PORT}
+${comp}_BUILD_DEPENDS?= ${${comp}_PATH}:${${comp}_PORT}
+${comp}_RUN_DEPENDS?= ${${comp}_PATH}:${${comp}_PORT}
${comp}_build_BUILD_DEPENDS?= ${${comp}_BUILD_DEPENDS}
${comp}_run_RUN_DEPENDS?= ${${comp}_RUN_DEPENDS}
_USE_QT_ALL_SUFFIXED+= ${comp} ${comp}_build ${comp}_run