aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.ruby.mk
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-06-19 20:42:45 +0800
committerstas <stas@FreeBSD.org>2009-06-19 20:42:45 +0800
commit8abc2f4e8aa2d4475b91f48e9b09fd4758ff91de (patch)
treebd7e955ed22b957261fbea3e879a92fb61a48a3c /Mk/bsd.ruby.mk
parent26301273e3bf570440a2442318b67364c2f847f3 (diff)
downloadfreebsd-ports-gnome-8abc2f4e8aa2d4475b91f48e9b09fd4758ff91de.tar.gz
freebsd-ports-gnome-8abc2f4e8aa2d4475b91f48e9b09fd4758ff91de.tar.zst
freebsd-ports-gnome-8abc2f4e8aa2d4475b91f48e9b09fd4758ff91de.zip
- Fix stack overflow detection algorithm. It has not worked before as
we were linking the ruby binary against pthreads, and the default stack size detection method with getrlimit didn't returned right values in this case. Now, if threads enabled, it also tries to determine the stack size via pthreads calls and use this value if it is smaller than what getrlimit returned. Furthermore, the stack overflow detection routine now works proactively, generating exception if there're probability the stack will be exhausted by the time of the next check (ruby performs checks only in each 256th call of rb_call0). [1] - Build pthreads-enabled ruby by default. I have not received any bug reports for this for years, and this verison will work correctly with threaded libraries. Also, do not link agains pthreads in non-pthread case (this breaks stack size detection algorithm), and eliminate the option to disable pthreads (so only power users who know what they're doing can disable them). - Build RDoc by default so it is available in the package. - Bump portrevision. PR: ports/132158 Reported by: Eugene Pimenov <libc@libc.st>
Diffstat (limited to 'Mk/bsd.ruby.mk')
-rw-r--r--Mk/bsd.ruby.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index 694a88f3bb21..5193c0250dde 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -170,7 +170,7 @@ RUBY?= ${LOCALBASE}/bin/${RUBY_NAME}
# Ruby 1.8
#
RUBY_RELVERSION= 1.8.7
-RUBY_PORTREVISION= 2
+RUBY_PORTREVISION= 3
RUBY_PORTEPOCH= 1
RUBY_PATCHLEVEL= 160