aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.ruby.mk
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-08-04 20:34:50 +0800
committererwin <erwin@FreeBSD.org>2006-08-04 20:34:50 +0800
commit983dc15ba8f877d94d8e2b8c777deb8199f4ec99 (patch)
treeb75af0a340e3a5fb325b96ab4419867bc2a7a996 /Mk/bsd.ruby.mk
parent0aec5ee33513f1341433ac3950105867e7edbae9 (diff)
downloadfreebsd-ports-gnome-983dc15ba8f877d94d8e2b8c777deb8199f4ec99.tar.gz
freebsd-ports-gnome-983dc15ba8f877d94d8e2b8c777deb8199f4ec99.tar.zst
freebsd-ports-gnome-983dc15ba8f877d94d8e2b8c777deb8199f4ec99.zip
Add support for DESTDIR part I.
This commit should largele be a NOOP as it only adds support for DESTDIR undefined. This does allow us to start testing ports with DESTDIR set, but this is as of yet not supported. Although this has been extensively tested on pointyhat, this is a very intrusive change and some cases may have been overlooked. Please contact Gabor and me if you find any. PR: 100555 Submitted by: gabor Sponsored by: Google Summer of Code 2006
Diffstat (limited to 'Mk/bsd.ruby.mk')
-rw-r--r--Mk/bsd.ruby.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index b0b7a8addc8d..ea8e147db544 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -113,7 +113,7 @@ RUBY_DEFAULT_VER?= 1.8
RUBY_VER?= ${RUBY_DEFAULT_VER}
.if defined(RUBY)
-.if !exists(${RUBY})
+.if !exists(${DESTDIR}${RUBY})
IGNORE= cannot install: you set the variable RUBY to "${RUBY}", but it does not seem to exist. Please specify an already installed ruby executable.
.endif
@@ -122,7 +122,7 @@ _RUBY_TEST!= ${RUBY} -e 'begin; require "rbconfig"; rescue LoadError; puts "err
IGNORE= cannot install: you set the variable RUBY to "${RUBY}", but it failed to include rbconfig. Please specify a properly installed ruby executable.
.endif
-_RUBY_CONFIG= ${RUBY} -r rbconfig -e 'C = Config::CONFIG' -e
+_RUBY_CONFIG= ${DESTDIR}${RUBY} -r rbconfig -e 'C = Config::CONFIG' -e
RUBY_VERSION!= ${_RUBY_CONFIG} 'puts VERSION'
RUBY_SUFFIX?= # empty