aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.sdl.mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2016-03-27 09:23:25 +0800
committerbapt <bapt@FreeBSD.org>2016-03-27 09:23:25 +0800
commitabad7303e73a8cabd7adccf1ad6e45c50e32dd80 (patch)
treefc37977964ca6fcbf75112d387272790e3517c83 /Mk/bsd.sdl.mk
parentf5daf2a12b960f9313921d87e8717cb262fe70d1 (diff)
downloadfreebsd-ports-gnome-abad7303e73a8cabd7adccf1ad6e45c50e32dd80.tar.gz
freebsd-ports-gnome-abad7303e73a8cabd7adccf1ad6e45c50e32dd80.tar.zst
freebsd-ports-gnome-abad7303e73a8cabd7adccf1ad6e45c50e32dd80.zip
Remove the now unneeded ${PORTSDIR} from dependency definition in
The infrastructure Makefiles PR: 206569 Exp run by: antoine Differential Revision: D5047
Diffstat (limited to 'Mk/bsd.sdl.mk')
-rw-r--r--Mk/bsd.sdl.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.sdl.mk b/Mk/bsd.sdl.mk
index 4e93b8303c5f..dbd503cc6e0c 100644
--- a/Mk/bsd.sdl.mk
+++ b/Mk/bsd.sdl.mk
@@ -161,20 +161,20 @@ __USE_SDL+= ${component}
# Finally make the list of libs required
#
.for component in ${__USE_SDL}
-LIB_DEPENDS+= ${_LIB_${component}}:${PORTSDIR}/${_SUBDIR_${component}}/${_PORTDIR_${component}}
+LIB_DEPENDS+= ${_LIB_${component}}:${_SUBDIR_${component}}/${_PORTDIR_${component}}
.endfor
#
# "Normal" dependencies and variables
#
.if ${__USE_SDL:Msdl} != ""
-BUILD_DEPENDS+= ${SDL_CONFIG}:${PORTSDIR}/${_SUBDIR_sdl}/${_PORTDIR_sdl}
+BUILD_DEPENDS+= ${SDL_CONFIG}:${_SUBDIR_sdl}/${_PORTDIR_sdl}
SDL_CONFIG?= ${LOCALBASE}/bin/sdl-config
CONFIGURE_ENV+= SDL_CONFIG=${SDL_CONFIG}
MAKE_ENV+= SDL_CONFIG=${SDL_CONFIG}
.endif
.if ${__USE_SDL:Msdl2} != ""
-BUILD_DEPENDS+= ${SDL2_CONFIG}:${PORTSDIR}/${_SUBDIR_sdl2}/${_PORTDIR_sdl2}
+BUILD_DEPENDS+= ${SDL2_CONFIG}:${_SUBDIR_sdl2}/${_PORTDIR_sdl2}
SDL2_CONFIG?= ${LOCALBASE}/bin/sdl2-config
CONFIGURE_ENV+= SDL2_CONFIG=${SDL2_CONFIG}
MAKE_ENV+= SDL2_CONFIG=${SDL2_CONFIG}