aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.sdl.mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-10-15 15:36:38 +0800
committerbapt <bapt@FreeBSD.org>2015-10-15 15:36:38 +0800
commitae4dc2bafba0b1aabb1bb4e42b36f62c23457820 (patch)
tree5d8c3107710b83c424eab2d353c0ea7b09e9816f /Mk/bsd.sdl.mk
parent6b6695087f949dae5e3bfd5f89e4e23cfdb9ae27 (diff)
downloadfreebsd-ports-gnome-ae4dc2bafba0b1aabb1bb4e42b36f62c23457820.tar.gz
freebsd-ports-gnome-ae4dc2bafba0b1aabb1bb4e42b36f62c23457820.tar.zst
freebsd-ports-gnome-ae4dc2bafba0b1aabb1bb4e42b36f62c23457820.zip
Readd PORTSDIR for now we will only start removing them after 2016Q1 is branched
This gives more time for tools to get updated, available in packages etc before bothering users
Diffstat (limited to 'Mk/bsd.sdl.mk')
-rw-r--r--Mk/bsd.sdl.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/bsd.sdl.mk b/Mk/bsd.sdl.mk
index 5ed1941b12f5..de3bdfb11a63 100644
--- a/Mk/bsd.sdl.mk
+++ b/Mk/bsd.sdl.mk
@@ -46,7 +46,7 @@ _USE_SDL_ALL+= gfx2 image2 mixer2 net2 sdl2 ttf2
#
# Variables used to determine what is needed:
# _SUBDIR_xxx subdirectory below ${PORTSDIR} (required)
-# _PORTDIR_xxx subdirectory below ${_SUBDIR_xxx}
+# _PORTDIR_xxx subdirectory below ${PORTSDIR}/${_SUBDIR_xxx}
# _LIB_xxx name of the shared lib
# _REQUIRES_xxx also needs these SDL libraries
#
@@ -192,20 +192,20 @@ __USE_SDL+= ${component}
# Finally make the list of libs required
#
.for component in ${__USE_SDL}
-LIB_DEPENDS+= ${_LIB_${component}}:${_SUBDIR_${component}}/${_PORTDIR_${component}}
+LIB_DEPENDS+= ${_LIB_${component}}:${PORTSDIR}/${_SUBDIR_${component}}/${_PORTDIR_${component}}
.endfor
#
# "Normal" dependencies and variables
#
.if ${__USE_SDL:Msdl} != ""
-BUILD_DEPENDS+= ${SDL_CONFIG}:${_SUBDIR_sdl}/${_PORTDIR_sdl}
+BUILD_DEPENDS+= ${SDL_CONFIG}:${PORTSDIR}/${_SUBDIR_sdl}/${_PORTDIR_sdl}
SDL_CONFIG?= ${LOCALBASE}/bin/sdl-config
CONFIGURE_ENV+= SDL_CONFIG=${SDL_CONFIG}
MAKE_ENV+= SDL_CONFIG=${SDL_CONFIG}
.endif
.if ${__USE_SDL:Msdl2} != ""
-BUILD_DEPENDS+= ${SDL2_CONFIG}:${_SUBDIR_sdl2}/${_PORTDIR_sdl2}
+BUILD_DEPENDS+= ${SDL2_CONFIG}:${PORTSDIR}/${_SUBDIR_sdl2}/${_PORTDIR_sdl2}
SDL2_CONFIG?= ${LOCALBASE}/bin/sdl2-config
CONFIGURE_ENV+= SDL2_CONFIG=${SDL2_CONFIG}
MAKE_ENV+= SDL2_CONFIG=${SDL2_CONFIG}