aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.sites.mk
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2013-01-24 06:33:53 +0800
committeradamw <adamw@FreeBSD.org>2013-01-24 06:33:53 +0800
commit170a2d6c6ed23b7482923215fa6dfa010f81c439 (patch)
tree6bdca624ff88126a84bb4e3f6ed43079edb3b6ff /Mk/bsd.sites.mk
parentaad465dd582f1ffa83944d05dac44d622f62a2a3 (diff)
downloadfreebsd-ports-gnome-170a2d6c6ed23b7482923215fa6dfa010f81c439.tar.gz
freebsd-ports-gnome-170a2d6c6ed23b7482923215fa6dfa010f81c439.tar.zst
freebsd-ports-gnome-170a2d6c6ed23b7482923215fa6dfa010f81c439.zip
GitHub is such a nightmare for distfile fetching.
I added a comment showing an easy way to fetch a distfile from GitHub. Using this method, you don't need to track the 7-digit commit at all. In fact, the distfile name and its contents behave like a normal, sane distfile would.
Diffstat (limited to 'Mk/bsd.sites.mk')
-rw-r--r--Mk/bsd.sites.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/Mk/bsd.sites.mk b/Mk/bsd.sites.mk
index 7bbcc25a45d0..9aca1ec0ef3f 100644
--- a/Mk/bsd.sites.mk
+++ b/Mk/bsd.sites.mk
@@ -530,6 +530,13 @@ GH_PROJECT?= ${PORTNAME}
GH_TAGNAME?= ${DISTVERSION}
.endif
.endif
+#
+# Another way to simplify distfile fetching from GitHub, eliminating the need
+# to track 7-digit commits for each distfile, is to use the following:
+#
+# MASTER_SITES= https://github.com/GH_ACCOUNT/${PORTNAME}/archive/${DISTVERSION}.tar.gz?dummy=/
+# FETCH_ARGS= -prR
+#
.if !defined(IGNORE_MASTER_SITE_GNOME)
MASTER_SITE_GNOME+= \