aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.wx.mk
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-12-04 02:04:39 +0800
committerpav <pav@FreeBSD.org>2006-12-04 02:04:39 +0800
commite2fe539088b9e1711cd9e57ba61648b3cc3c5eaf (patch)
tree6f37ac1a56f63987585c796bd67a28315adbd7df /Mk/bsd.wx.mk
parent418724d9b3ba3e21ef0e68c2b9c511f4148d7cd4 (diff)
downloadfreebsd-ports-gnome-e2fe539088b9e1711cd9e57ba61648b3cc3c5eaf.tar.gz
freebsd-ports-gnome-e2fe539088b9e1711cd9e57ba61648b3cc3c5eaf.tar.zst
freebsd-ports-gnome-e2fe539088b9e1711cd9e57ba61648b3cc3c5eaf.zip
- Skip versions for which requested component is not available. Fixes ports
that define USE_WX= 2.4+ WX_COMPS= python
Diffstat (limited to 'Mk/bsd.wx.mk')
-rw-r--r--Mk/bsd.wx.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/Mk/bsd.wx.mk b/Mk/bsd.wx.mk
index 842ab999310f..8c010737eadd 100644
--- a/Mk/bsd.wx.mk
+++ b/Mk/bsd.wx.mk
@@ -136,6 +136,14 @@ _WX_VERS_ALL= 2.4 2.6 2.8
_WX_VERS_UC_ALL= 2.6 2.8
_WX_VERS_LISTS= WANT_WX_VER WITH_WX_VER
+# _WX_ILLEGAL_VERS_PYTHON - List of versions where wxPython is not available
+# _WX_ILLEGAL_VERS_MOZILLA - List of versions where wxmozilla is not available
+# _WX_ILLEGAL_VERS_SVG - List of versions where wxsvg is not available
+
+_WX_ILLEGAL_VERS_PYTHON= 2.8
+_WX_ILLEGAL_VERS_MOZILLA= 2.6 2.8
+_WX_ILLEGAL_VERS_SVG= 2.4 2.8
+
#
# Variables used to determine what is needed:
# _WX_PORT_comp_ver - Port directory.
@@ -386,6 +394,28 @@ _WX_UCL= #
_WX_PYSUFX= -ansi
.endif
+# Limit range of possible versions for python, svg and mozila
+
+.for comp in ${WX_COMPS}
+_WX_COMP= ${comp}
+. if ${_WX_COMP} == "python"
+. for excl in ${_WX_ILLEGAL_VERS_PYTHON}
+_WX_VER_FINAL:= ${_WX_VER_FINAL:S/${excl}//}
+. endfor
+. endif
+. if ${_WX_COMP} == "mozilla"
+. for excl in ${_WX_ILLEGAL_VERS_MOZILLA}
+_WX_VER_FINAL:= ${_WX_VER_FINAL:S/${excl}//}
+. endfor
+. endif
+. if ${_WX_COMP} == "svg"
+. for excl in ${_WX_ILLEGAL_VERS_SVG}
+_WX_VER_FINAL:= ${_WX_VER_FINAL:S/${excl}//}
+. endfor
+. endif
+.endfor
+
+
#
# Choose final version.
#