aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-04-04 16:14:24 +0800
committerbapt <bapt@FreeBSD.org>2014-04-04 16:14:24 +0800
commit14f5e8602a6660495bab8bfc305dc17bf8288f8d (patch)
tree2646c633fca98ce8b2a3596ec7c4d6b5024f254a /Mk
parent26a5c647512df8370d6b880bcabcf86a8c52ceae (diff)
downloadfreebsd-ports-gnome-14f5e8602a6660495bab8bfc305dc17bf8288f8d.tar.gz
freebsd-ports-gnome-14f5e8602a6660495bab8bfc305dc17bf8288f8d.tar.zst
freebsd-ports-gnome-14f5e8602a6660495bab8bfc305dc17bf8288f8d.zip
Use bmake features to easier cross building support
This makes cross building only work with bmake given it is only supported on FreeBSD 10+ this is not a problem
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 87fecab5e802..f7c911435d06 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1136,6 +1136,9 @@ NOTPHONY?=
.if defined(NO_STAGE)
IGNORE= Cross building is only compatible with stagified ports
.endif
+.if defined(.PARSEDIR)
+IGNORE= Cross building can only be done when using bmake(1) as make(1)
+.endif
BUILD_DEPENDS= ${X_BUILD_FOR}-cc:${PORTSDIR}/devel/${X_BUILD_FOR}-xdev
# Do not define CPP on purpose
.if !defined(HCC)
@@ -1148,6 +1151,9 @@ NM= ${X_BUILD_FOR}-nm
STRIP_CMD= ${X_BUILD_FOR}-strip
MAKE_ENV+= NM=${NM} STRIPBIN=${X_BUILD_FOR}-strip
PKG_ENV+= ABI_FILE=${LOCALBASE}/${X_BUILD_FOR}/usr/lib/crt1.o
+# only bmake support the below
+STRIPBIN= ${STRIP_CMD}
+.export.env STRIPBIN
.endif
#