aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1998-07-29 06:27:16 +0800
committerobrien <obrien@FreeBSD.org>1998-07-29 06:27:16 +0800
commit26a0959a8bebc9f7ba078e1e4e38c5e1f52af4b6 (patch)
treec0f5205c212536ed4b92ef5842981d7f28ab163f /Mk
parenta2963d147e59e86157a3f3373c6130a875673de3 (diff)
downloadfreebsd-ports-gnome-26a0959a8bebc9f7ba078e1e4e38c5e1f52af4b6.tar.gz
freebsd-ports-gnome-26a0959a8bebc9f7ba078e1e4e38c5e1f52af4b6.tar.zst
freebsd-ports-gnome-26a0959a8bebc9f7ba078e1e4e38c5e1f52af4b6.zip
Add var "CD_MOUNTPT" set to /cdrom by default.
Ok'ed by: discussed with Satoshi at USENIX
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk9
1 files changed, 5 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index d042161ca46d..c53c97245166 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1,7 +1,7 @@
#-*- mode: Fundamental; tab-width: 4; -*-
# ex:ts=4
#
-# $Id: bsd.port.mk,v 1.276 1998/05/20 22:27:18 jkh Exp $
+# $Id: bsd.port.mk,v 1.277 1998/07/13 23:39:02 se Exp $
# $NetBSD: $
#
# bsd.port.mk - 940820 Jordan K. Hubbard.
@@ -622,9 +622,10 @@ PATCH_SITES:= ${MASTER_SITE_OVERRIDE} ${PATCH_SITES}
# Search CDROM first if mounted, symlink instead of copy if
# FETCH_SYMLINK_DISTFILES is set
-.if exists(/cdrom/ports/distfiles)
-MASTER_SITES:= file:/cdrom/ports/distfiles/${DIST_SUBDIR}/ ${MASTER_SITES}
-PATCH_SITES:= file:/cdrom/ports/distfiles/${DIST_SUBDIR}/ ${PATCH_SITES}
+CD_MOUNTPT?= /cdrom
+.if exists(${CD_MOUNTPT}/ports/distfiles)
+MASTER_SITES:= file:${CD_MOUNTPT}/ports/distfiles/${DIST_SUBDIR}/ ${MASTER_SITES}
+PATCH_SITES:= file:${CD_MOUNTPT}/ports/distfiles/${DIST_SUBDIR}/ ${PATCH_SITES}
.if defined(FETCH_SYMLINK_DISTFILES)
FETCH_BEFORE_ARGS+= -l
.endif