aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-04-19 15:29:44 +0800
committerperky <perky@FreeBSD.org>2004-04-19 15:29:44 +0800
commit2ab5e1e6de3a9d70fa8bc5890fa66937785cb9a4 (patch)
treefb82da25bee5d2adb0a637bcd441a1dd128e54d5 /Mk
parent6b08c8c38421635bac55ddcb5a31038e2a3df1bf (diff)
downloadfreebsd-ports-gnome-2ab5e1e6de3a9d70fa8bc5890fa66937785cb9a4.tar.gz
freebsd-ports-gnome-2ab5e1e6de3a9d70fa8bc5890fa66937785cb9a4.tar.zst
freebsd-ports-gnome-2ab5e1e6de3a9d70fa8bc5890fa66937785cb9a4.zip
- Enable ZOPE directory variables to be overridden in make.conf.
- Install 3rd party products to the right place. PR: 65608 Submitted by: Gerhard Sschmidt <estartu@augusta.de>
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.python.mk11
1 files changed, 2 insertions, 9 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index f01f749bf845..34e0a90d8e31 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -115,10 +115,6 @@ Python_Include_MAINTAINER= perky@FreeBSD.org
_PYTHON_PORTBRANCH= 2.3
_PYTHON_ALLBRANCHES= 2.3 2.2 2.1 2.0 1.5 2.4 # preferred first
-.if defined(USE_ZOPE)
-PYTHON_VERSION= python2.3
-.endif
-
.if defined(PYTHON_VERSION)
_PYTHON_VERSION!= echo "${PYTHON_VERSION}" | ${SED} 's/^python//'
_PYTHON_CMD= ${LOCALBASE}/bin/${PYTHON_VERSION}
@@ -295,12 +291,9 @@ PYDISTUTILS_INSTALLARGS?= -c -O1 --prefix=${PREFIX}
# Zope specific variables
.if defined(USE_ZOPE)
-# You can change this in the environment if you like
SZOPEBASEDIR?= www/Zope
-# Don't change these. You'll probably want to define ZOPEPRODUCTNAME,
-# too, but that is port-specific.
-ZOPEBASEDIR= ${PREFIX}/${SZOPEBASEDIR}
-ZOPEPRODUCTDIR= lib/python/Products
+ZOPEBASEDIR?= ${PREFIX}/${SZOPEBASEDIR}
+ZOPEPRODUCTDIR?= Products
.endif
.if defined(PYTHON_REL) && ${PYTHON_REL} < 200