aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-05-07 01:43:11 +0800
committerantoine <antoine@FreeBSD.org>2014-05-07 01:43:11 +0800
commit3158311af530facd34e7e11028da8cfa8e064976 (patch)
tree1d3e82915771a66cbae40dd7871e7ab68f9418e0 /Mk
parentf409361b94540bcf1126917f70487fff2fb255d0 (diff)
downloadfreebsd-ports-gnome-3158311af530facd34e7e11028da8cfa8e064976.tar.gz
freebsd-ports-gnome-3158311af530facd34e7e11028da8cfa8e064976.tar.zst
freebsd-ports-gnome-3158311af530facd34e7e11028da8cfa8e064976.zip
When a port needs a python version in a specific range that current python
doesn't satisfy, prefer PYTHON2_DEFAULT or PYTHON3_DEFAULT over other versions. Previously, python34 was choosen despite python33 being the default python3. Silence from: python With hat: portmgr
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.python.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index f5364b7f7cae..57825802626a 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -289,7 +289,7 @@ IGNORE= needs Python ${_PYTHON_VERSION_NONSUPPORTED}.\
But you specified ${_PYTHON_VERSION}
.else
.undef _PYTHON_VERSION
-.for ver in ${_PYTHON_ALLBRANCHES}
+.for ver in ${PYTHON2_DEFAULT} ${PYTHON3_DEFAULT} ${_PYTHON_ALLBRANCHES}
__VER= ${ver}
.if !defined(_PYTHON_VERSION) && \
!(!empty(_PYTHON_VERSION_MINIMUM) && ( \