aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-28 23:59:47 +0800
committerbapt <bapt@FreeBSD.org>2014-05-28 23:59:47 +0800
commit460b3a7551b4e9ea24602681313272ad14e6edd6 (patch)
tree2217a06aba9c2ccdf97eb3c5097c95cb5262de51 /Mk
parent6e72861e511da4a3707a9fa9c78f05f108b64e6f (diff)
downloadfreebsd-ports-gnome-460b3a7551b4e9ea24602681313272ad14e6edd6.tar.gz
freebsd-ports-gnome-460b3a7551b4e9ea24602681313272ad14e6edd6.tar.zst
freebsd-ports-gnome-460b3a7551b4e9ea24602681313272ad14e6edd6.zip
Add a new option, INSTALL_STRIPPED,
which is intended to be used with WITH_DEBUG, allowing the system to build packages with debugging symbols enabled and kept in build environment but do not install them with the resulting binaries. PR: ports/185309 Submitted by: delphij Reviewed by: bdrewery
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 25d2bab66a25..50c917a28529 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1619,9 +1619,11 @@ CFLAGS:= ${CFLAGS:C/${_CPUCFLAGS}//}
# Reset value from bsd.own.mk.
.if defined(WITH_DEBUG) && !defined(WITHOUT_DEBUG)
+.if !defined(INSTALL_STRIPPED)
STRIP= #none
MAKE_ENV+= DONTSTRIP=yes
STRIP_CMD= ${TRUE}
+.endif
DEBUG_FLAGS?= -g
CFLAGS:= ${CFLAGS:N-O*:N-fno-strict*} ${DEBUG_FLAGS}
.if defined(INSTALL_TARGET)