aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-05-31 13:04:04 +0800
committerbapt <bapt@FreeBSD.org>2012-05-31 13:04:04 +0800
commit61e433a722de08888302255e67ac94d2798696ef (patch)
treee2e3cacaedc49a6010918a0461e95771670b253c /Mk
parent6f33e845d63210953fbc3b065bdff7e168615e2a (diff)
downloadfreebsd-ports-gnome-61e433a722de08888302255e67ac94d2798696ef.tar.gz
freebsd-ports-gnome-61e433a722de08888302255e67ac94d2798696ef.tar.zst
freebsd-ports-gnome-61e433a722de08888302255e67ac94d2798696ef.zip
Stop spawning dialog inside its own sh process
This allow us to use normal make quoting when preparing the command line for the make config dialog
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk14
1 files changed, 7 insertions, 7 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 9bfb2dfa17a9..271ca1415e35 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -5997,18 +5997,18 @@ pre-config:
_COMPLETE_OPTIONS_LIST:= ${ALL_OPTIONS}
.for opt in ${ALL_OPTIONS}
. if empty(PORT_OPTIONS:M${opt})
-DEFOPTIONS+= ${opt} "${${opt}_DESC:S|"||g:S|'| |g}" off
+DEFOPTIONS+= ${opt} ${${opt}_DESC:Q} off
. else
-DEFOPTIONS+= ${opt} "${${opt}_DESC:S|"||g:S|'| |g}" on
+DEFOPTIONS+= ${opt} ${${opt}_DESC:Q} on
. endif
.endfor
.for multi in ${OPTIONS_MULTI}
. for opt in ${OPTIONS_MULTI_${multi}}
_COMPLETE_OPTIONS_LIST+= ${opt}
. if empty(PORT_OPTIONS:M${opt})
-DEFOPTIONS+= ${opt} "M(${multi}): ${${opt}_DESC:S|"||g:S|'| |g}" off
+DEFOPTIONS+= ${opt} "M(${multi}): "${${opt}_DESC:Q} off
. else
-DEFOPTIONS+= ${opt} "M(${multi}): ${${opt}_DESC:S|"||g:S|'| |g}" on
+DEFOPTIONS+= ${opt} "M(${multi}): "${${opt}_DESC:Q} on
. endif
. endfor
.endfor
@@ -6016,9 +6016,9 @@ DEFOPTIONS+= ${opt} "M(${multi}): ${${opt}_DESC:S|"||g:S|'| |g}" on
. for opt in ${OPTIONS_SINGLE_${single}}
_COMPLETE_OPTIONS_LIST+= ${opt}
. if empty(PORT_OPTIONS:M${opt})
-DEFOPTIONS+= ${opt} "S(${single}): ${${opt}_DESC:S|"||g:S|'| |g}" off
+DEFOPTIONS+= ${opt} "S(${single}): "${${opt}_DESC:Q} off
. else
-DEFOPTIONS+= ${opt} "S(${single}): ${${opt}_DESC:S|"||g:S|'| |g}" on
+DEFOPTIONS+= ${opt} "S(${single}): "${${opt}_DESC:Q} on
. endif
. endfor
.endfor
@@ -6047,7 +6047,7 @@ config: pre-config
.endif
@TMPOPTIONSFILE=$$(mktemp -t portoptions); \
trap "${RM} -f $${TMPOPTIONSFILE}; exit 1" 1 2 3 5 10 13 15; \
- ${SH} -c '${DIALOG} --checklist "Options for ${PKGNAME:C/-([^-]+)$/ \1/}" 21 70 15 ${DEFOPTIONS}' 2> $${TMPOPTIONSFILE} || { \
+ ${DIALOG} --checklist "Options for ${PKGNAME:C/-([^-]+)$/ \1/}" 21 70 15 ${DEFOPTIONS} 2> $${TMPOPTIONSFILE} || { \
${RM} -f $${TMPOPTIONSFILE}; \
${ECHO_MSG} "===> Options unchanged"; \
exit 0; \