aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2006-09-20 19:21:59 +0800
committerstas <stas@FreeBSD.org>2006-09-20 19:21:59 +0800
commit690719e4d56669840ac4b9264f949634ed10d1c1 (patch)
treef8a62d437d458241263339bd8d7a8582056207da /Mk
parent5cbdf409c7db9b9d115b500f9084c97595f61719 (diff)
downloadfreebsd-ports-gnome-690719e4d56669840ac4b9264f949634ed10d1c1.tar.gz
freebsd-ports-gnome-690719e4d56669840ac4b9264f949634ed10d1c1.tar.zst
freebsd-ports-gnome-690719e4d56669840ac4b9264f949634ed10d1c1.zip
- Update devel/sdl12 to version 1.2.11. Now we employ stock SDL directory
structure (i.e. include/SDL for includes and sdl-config for configuration binary) - Update graphics/sdl_ttf to version 2.0.8 - Update graphics/sdl_image to version 1.2.5 - Update audio/sdl_mixer to version 1.2.7 - Update net/sdl_net to version 1.2.6 - Update Mk/bsd.sdl.mk accordingly - Fix dependent ports to fit the new directory structure and avoid several API breakages - Bump up portrevisions for all dependent ports to allow them to be upgraded by portupgrade/portmaster etc tools Approved by: kris (portmgr), sem (mentor)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.sdl.mk11
1 files changed, 5 insertions, 6 deletions
diff --git a/Mk/bsd.sdl.mk b/Mk/bsd.sdl.mk
index ae1dc5bf5802..52e0adcbe313 100644
--- a/Mk/bsd.sdl.mk
+++ b/Mk/bsd.sdl.mk
@@ -56,7 +56,7 @@ _VERSION_gui= 0
_SUBDIR_gui= x11-toolkits
_REQUIRES_gui= sdl image ttf
-_VERSION_image= 10
+_VERSION_image= 1
_SUBDIR_image= graphics
_REQUIRES_image=sdl
@@ -74,17 +74,16 @@ _VERSION_net= 0
_SUBDIR_net= net
_REQUIRES_net= sdl
-_VERSION_sdl= 7
+_VERSION_sdl= 11
_SUBDIR_sdl= devel
-_LIB_sdl= SDL-1.1
+_LIB_sdl= SDL
_PORTDIR_sdl= sdl12
_VERSION_sound= 1
_SUBDIR_sound= audio
-_LIB_sound= SDL_sound-1.0
_REQUIRES_sound=sdl
-_VERSION_ttf= 3
+_VERSION_ttf= 6
_SUBDIR_ttf= graphics
_REQUIRES_ttf= sdl
@@ -171,7 +170,7 @@ LIB_DEPENDS+= ${_LIB_${component}}.${_VERSION_${component}}:${PORTSDIR}/${_SUBDI
# "Normal" dependencies and variables
#
BUILD_DEPENDS+= ${SDL_CONFIG}:${PORTSDIR}/${_SUBDIR_sdl}/${_PORTDIR_sdl}
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl-config
CONFIGURE_ENV+= SDL_CONFIG=${SDL_CONFIG}
MAKE_ENV+= SDL_CONFIG=${SDL_CONFIG}