aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2013-12-06 16:20:16 +0800
committerak <ak@FreeBSD.org>2013-12-06 16:20:16 +0800
commit775ad76e71b13f6467fe2c0b7547cdf3ed2fc7e4 (patch)
treefc98a74cf3c1518b4352b0033eab2ccd692cfdf1 /Mk
parent950fec73b16ec918692cac85d7f4ddb444e27cee (diff)
downloadfreebsd-ports-gnome-775ad76e71b13f6467fe2c0b7547cdf3ed2fc7e4.tar.gz
freebsd-ports-gnome-775ad76e71b13f6467fe2c0b7547cdf3ed2fc7e4.tar.zst
freebsd-ports-gnome-775ad76e71b13f6467fe2c0b7547cdf3ed2fc7e4.zip
- Implement support for architecture-neutral ports
- Replace 'alpha' with 'amd64' - Remove gratuitous whitespaces at the end of the line Approved by: portmgr (bapt)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.pkgng.mk7
-rw-r--r--Mk/bsd.port.mk20
2 files changed, 16 insertions, 11 deletions
diff --git a/Mk/bsd.pkgng.mk b/Mk/bsd.pkgng.mk
index 75c3f3e1afff..f279e8d59f7a 100644
--- a/Mk/bsd.pkgng.mk
+++ b/Mk/bsd.pkgng.mk
@@ -39,12 +39,15 @@ ACTUAL-PACKAGE-DEPENDS?= \
create-manifest:
@${MKDIR} ${METADIR}
@${ECHO_CMD} "name: ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}" > ${MANIFESTF}
- @${ECHO_CMD} "version: ${PKGVERSION}" >> ${MANIFESTF}
- @${ECHO_CMD} "origin: ${PKGORIGIN}" >> ${MANIFESTF}
+ @${ECHO_CMD} "version: ${PKGVERSION}" >> ${MANIFESTF}
+ @${ECHO_CMD} "origin: ${PKGORIGIN}" >> ${MANIFESTF}
@${ECHO_CMD} "comment: |" >> ${MANIFESTF}
@${ECHO_CMD} " "${COMMENT:Q} >> ${MANIFESTF}
@${ECHO_CMD} "maintainer: ${MAINTAINER}" >> ${MANIFESTF}
@${ECHO_CMD} "prefix: ${PREFIX}" >> ${MANIFESTF}
+.if defined(NOARCH)
+ @${ECHO_CMD} "arch: `${PKG_BIN} config abi | ${CUT} -d: -f1,2`:*" >> ${MANIFESTF}
+.endif
.if defined(WWW)
@${ECHO_CMD} "www: ${WWW}" >> ${MANIFESTF}
.endif
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 0aa357b6c1d3..94085d035aa6 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -69,7 +69,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# PKGNAMEPREFIX - Prefix to specify that port is language-specific, etc.
# Optional.
# PKGNAMESUFFIX - Suffix to specify compilation options or a version
-# designator (in case there are different versions of
+# designator (in case there are different versions of
# one port as is the case for Tcl).
# Optional.
# PKGVERSION - Always defined as ${PORTVERSION}.
@@ -215,8 +215,10 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# generated on the fly.
# Default: not set.
#
+# NOARCH - Set this if port is architecture neutral.
+#
# Set these if your port only makes sense to certain architectures.
-# They are lists containing names for them (e.g., "alpha i386").
+# They are lists containing names for them (e.g., "amd64 i386").
# (Defaults: not set.)
#
# ONLY_FOR_ARCHS
@@ -815,7 +817,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# Default: none
# FETCH_REGET - Times to retry fetching of files on checksum errors.
# Default: 1
-# CLEAN_FETCH_ENV
+# CLEAN_FETCH_ENV
# - Disable package dependency in fetch target for mass
# fetching. User settable.
#
@@ -1139,7 +1141,7 @@ LIB_DIRS?= /lib /usr/lib ${LOCALBASE}/lib
.undef NO_STAGE
.endif
-# make sure bmake treats -V as expected
+# make sure bmake treats -V as expected
.MAKE.EXPAND_VARIABLES= yes
# tell bmake we use the old :L :U modifiers
.MAKE.FreeBSD_UL= yes
@@ -1575,7 +1577,7 @@ CONFIGURE_WRKSRC?= ${WRKSRC}
BUILD_WRKSRC?= ${WRKSRC}
INSTALL_WRKSRC?=${WRKSRC}
-PLIST_SUB+= OSREL=${OSREL} PREFIX=%D LOCALBASE=${LOCALBASE}
+PLIST_SUB+= OSREL=${OSREL} PREFIX=%D LOCALBASE=${LOCALBASE}
SUB_LIST+= PREFIX=${PREFIX} LOCALBASE=${LOCALBASE} \
DATADIR=${DATADIR} DOCSDIR=${DOCSDIR} EXAMPLESDIR=${EXAMPLESDIR} \
WWWDIR=${WWWDIR} ETCDIR=${ETCDIR}
@@ -2323,7 +2325,7 @@ INSTALL_PROGRAM= \
INSTALL_KLD= \
${INSTALL} ${COPY} ${_BINOWNGRP} -m ${BINMODE}
INSTALL_LIB= \
- ${INSTALL} ${COPY} ${STRIP} ${_SHROWNGRP} -m ${SHAREMODE}
+ ${INSTALL} ${COPY} ${STRIP} ${_SHROWNGRP} -m ${SHAREMODE}
INSTALL_SCRIPT= \
${INSTALL} ${COPY} ${_BINOWNGRP} -m ${BINMODE}
INSTALL_DATA= \
@@ -3008,7 +3010,7 @@ _MANPAGES+= ${MAN${sect}_${manlang:S%^man/%%:U}:S%^%${MAN${sect}PREFIX}/${manlan
.endfor
# Special case for English, since it is defined with "" in MANLANG rather than
-# a language name and does not have man pages installed in a lang subdirectory
+# a language name and does not have man pages installed in a lang subdirectory
# of MAN${sect}PREFIX.
.for sect in 1 2 3 4 5 6 7 8 9 L N
.if defined(MAN${sect}_EN)
@@ -4296,7 +4298,7 @@ create-users-groups:
.endif
# PR ports/152498
-# XXX Make sure the commands to create group(s)
+# XXX Make sure the commands to create group(s)
# and user(s) are the first in pkg-plist
.if !target(fix-plist-sequence)
fix-plist-sequence: ${TMPPLIST}
@@ -5868,7 +5870,7 @@ generate-plist:
@if [ -f ${PLIST} ]; then \
${SED} ${PLIST_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${PLIST} >> ${TMPPLIST}; \
fi
-
+
.for dir in ${PLIST_DIRS}
@${ECHO_CMD} ${dir} | ${SED} ${PLIST_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} -e 's,^,@dirrm ,' >> ${TMPPLIST}
.endfor