aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-04-08 21:10:25 +0800
committerkoobs <koobs@FreeBSD.org>2014-04-08 21:10:25 +0800
commit87beb89bea686ef079c59dfcc7aa6a16940edf08 (patch)
tree7ce51cb70563be00f7ba45bd8ed641515075d40a /Mk
parent88f610090efb7470ea3965793e5883492ac77eb4 (diff)
downloadfreebsd-ports-gnome-87beb89bea686ef079c59dfcc7aa6a16940edf08.tar.gz
freebsd-ports-gnome-87beb89bea686ef079c59dfcc7aa6a16940edf08.tar.zst
freebsd-ports-gnome-87beb89bea686ef079c59dfcc7aa6a16940edf08.zip
Welcome Python 3.4 to the FreeBSD Ports Tree!
The FreeBSD Python Team warmly welcomes Python 3.4 to the Ports tree: - Add lang/python34 - Add devel/py-setuptools34 - Add Python 3.4.0 docs to lang/python-doc Release Announcement and Major Features: https://www.python.org/download/releases/3.4.0/ This also marks the next stage of a cleaner, much-closer-to-upstream approach to Python on FreeBSD, that builds upon the hard work of the entire FreeBSD Python team over the last year. This port is built "entirely" from scratch, retiring as much of the legacy, workarounds, patches and hacks from the existing Python ports as possible. Of particular note: static + shared dual-build is gone, as it was flaky at best, grossly untested upstream and caused more issues than it solved. It is replaced by a shared build by default. The static python library remains installed and usable. Major changes in this structure are: - Replace dual static and shared in-tree build with shared-only. - Use options helpers - Replace plat-freebsd* hacks with a lighter weight alternative - Strip all libraries and shared extensions - Only retain patches that are absolutely necessary - Replace static disabled_module_list with one from upstream - Retain NIS and sparc64 workarounds from python33 - Deprecate SEM option, no longer optional. - Deprecate PTH option, no longer maintained or supported upstream - Deprecate FPECTL option, no longer maintained or supported upstream - Add upstream issue references & breadcrumb annotations where possible Tested by: many (Special thanks to Andrew Berg) Reviewed by: xmj, nemysis, antoine
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.python.mk16
1 files changed, 14 insertions, 2 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 4b6287a0446c..0ae085df2aaa 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -194,7 +194,7 @@ Python_Include_MAINTAINER= python@FreeBSD.org
# default: ${LOCALBASE}/bin/easy_install-${PYTHON_VER}
_PYTHON_PORTBRANCH= 2.7
-_PYTHON_ALLBRANCHES= 2.7 3.3 3.2 3.1 # preferred first
+_PYTHON_ALLBRANCHES= 2.7 3.4 3.3 3.2 3.1 # preferred first
# Determine version number of Python to use
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
@@ -333,8 +333,19 @@ PYTHON_PORTVERSION= ${PYTHON_DEFAULT_PORTVERSION}
# Propagate the chosen python version to submakes.
.MAKEFLAGS: PYTHON_VERSION=python${_PYTHON_VERSION}
+# Python-3.4
+.if ${PYTHON_VERSION} == "python3.4"
+PYTHON_PORTVERSION?= 3.4.0
+PYTHON_PORTSDIR= ${PORTSDIR}/lang/python34
+PYTHON_REL= 340
+PYTHON_SUFFIX= 34
+PYTHON_VER= 3.4
+.if exists(${PYTHON_CMD}-config) && ${PORTNAME} != python34
+PYTHON_ABIVER!= ${PYTHON_CMD}-config --abiflags
+.endif
+
# Python-3.3
-.if ${PYTHON_VERSION} == "python3.3"
+.elif ${PYTHON_VERSION} == "python3.3"
PYTHON_PORTVERSION?= 3.3.5
PYTHON_PORTSDIR= ${PORTSDIR}/lang/python33
PYTHON_REL= 335
@@ -389,6 +400,7 @@ check-makevars::
@${ECHO} " python3.1"
@${ECHO} " python3.2"
@${ECHO} " python3.3"
+ @${ECHO} " python3.4"
@${FALSE}
.endif