aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-02-27 17:51:45 +0800
committertijl <tijl@FreeBSD.org>2014-02-27 17:51:45 +0800
commita4988754ea168fdd09f41824c530e93b44e0b433 (patch)
tree20c29bc3692602170fb3e35b18084dc0f3899aa4 /Mk
parentf787a299376330d88685e93e0f4d25455f86cc1e (diff)
downloadfreebsd-ports-gnome-a4988754ea168fdd09f41824c530e93b44e0b433.tar.gz
freebsd-ports-gnome-a4988754ea168fdd09f41824c530e93b44e0b433.tar.zst
freebsd-ports-gnome-a4988754ea168fdd09f41824c530e93b44e0b433.zip
- Some ports ship with libtool 1.5.x + "anygcc" patch. This modified
version calls "gcc" in two places. Replace that with $CC. - r346193 added -B${LOCALBASE}/bin in Uses/fortran.mk, just like compiler.mk, but libtool doesn't recognise this flag and discards it. Patch ltmain.sh so it passes the flag to the linker unmodified. This only works on libtool 2.x for now, but that's good enough to fix the PRs below and a linker error in math/octave on FreeBSD/i386 8.x. (When those ports set USES=libtool.) PR: ports/186946, ports/187000 Approved by: bapt
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/libtool.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/Mk/Uses/libtool.mk b/Mk/Uses/libtool.mk
index 89d2e3af9e02..92994f3a9ad9 100644
--- a/Mk/Uses/libtool.mk
+++ b/Mk/Uses/libtool.mk
@@ -19,12 +19,18 @@ _INCLUDE_USES_LIBTOOL_POST_MK= yes
patch-libtool:
@${FIND} ${WRKDIR} \( -name configure -or -name ltconfig \) \
-type f | ${XARGS} ${REINPLACE_CMD} \
+ -e '/gcc_dir=\\`/s/gcc /$$CC /' \
+ -e '/gcc_ver=\\`/s/gcc /$$CC /' \
-e '/link_all_deplibs[0-9A-Z_]*=/s/=unknown/=no/' \
-e 's,freebsd\*),freebsd\*|dragonfly\*),g' \
-e '/objformat=/s/echo aout/echo elf/' \
-e "/freebsd-elf\\*)/,/;;/ { \
/deplibs_check_method=/s/=.*/=pass_all/; }"
+ @${FIND} ${WRKDIR} -type f -name ltmain.sh | \
+ ${XARGS} ${REINPLACE_CMD} \
+ -e 's/|-p|-pg|/|-B*|-p|-pg|/'
+
.if ! ${libtool_ARGS:Moldver}
@${FIND} ${WRKDIR} \( -name configure -or -name ltconfig \) \
-type f | ${XARGS} ${REINPLACE_CMD} \