aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2001-05-02 19:49:36 +0800
committertg <tg@FreeBSD.org>2001-05-02 19:49:36 +0800
commita60abd85ccbcf4042a81101cc4320f4db3e98008 (patch)
treeb6805c13bc85b21d06afe9c330d14b7a4e50e19b /Mk
parent6f8193629c48fecd610aef57e6c5b58a4a41a197 (diff)
downloadfreebsd-ports-gnome-a60abd85ccbcf4042a81101cc4320f4db3e98008.tar.gz
freebsd-ports-gnome-a60abd85ccbcf4042a81101cc4320f4db3e98008.tar.zst
freebsd-ports-gnome-a60abd85ccbcf4042a81101cc4320f4db3e98008.zip
Python-2.1 is the new default version.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.python.mk27
1 files changed, 21 insertions, 6 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 54f71f25916c..9eafb1f0536c 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -77,21 +77,32 @@ Python_Include_MAINTAINER= tg@FreeBSD.org
# version number is substituted and the corresponding Python distribution
# will be built through the dependency processing.
_PYTHON_VERSION!= (python -c 'import sys; print sys.version[:3]') 2> /dev/null \
- || echo 2.0
+ || echo 2.1
PYTHON_VERSION?= python${_PYTHON_VERSION}
PYTHON_PORTVERSION!= (${PYTHON_VERSION} -c 'import string, sys; \
print string.split(sys.version)[0]') 2> /dev/null \
- || echo 2.0
+ || echo 2.1
+
+# Python-2.1
+.if ${PYTHON_VERSION} == "python2.1"
+PYDISTUTILS= ${PYTHON_LIBDIR}/distutils/core.py:${PYTHON_PORTSDIR}
+PYXML= ${PYTHON_SITELIBDIR}/_xmlplus/__init__.py:${PORTSDIR}/textproc/py-xml
+
+PYTHON_DISTFILE= Python-2.1.tgz
+PYTHON_PORTSDIR= ${PORTSDIR}/lang/python
+PYTHON_REL= 210
+PYTHON_SUFFIX= # empty, default version
+PYTHON_WRKSRC= ${WRKDIR}/Python-2.1
# Python-2.0
-.if ${PYTHON_VERSION} == "python2.0"
+.elif ${PYTHON_VERSION} == "python2.0"
PYDISTUTILS= ${PYTHON_LIBDIR}/distutils/core.py:${PYTHON_PORTSDIR}
PYXML= ${PYTHON_SITELIBDIR}/_xmlplus/__init__.py:${PORTSDIR}/textproc/py-xml
PYTHON_DISTFILE= BeOpen-Python-2.0.tar.gz
-PYTHON_PORTSDIR= ${PORTSDIR}/lang/python
+PYTHON_PORTSDIR= ${PORTSDIR}/lang/python20
PYTHON_REL= 200
-PYTHON_SUFFIX= # empty, default version
+PYTHON_SUFFIX= 20
PYTHON_WRKSRC= ${WRKDIR}/Python-2.0
# Python-1.6
@@ -123,7 +134,11 @@ PYTHON_WRKSRC= ${WRKDIR}/Python-1.5.2
.else
.BEGIN:
@${ECHO} "Error: bad value for PYTHON_VERSION: ${PYTHON_VERSION}."
- @${ECHO} "Use one of python1.5, python1.6 or python2.0 (default)."
+ @${ECHO} "Legal values are:"
+ @${ECHO} " python1.5"
+ @${ECHO} " python1.6"
+ @${ECHO} " python2.0"
+ @${ECHO} " python2.1 (default)."
@${FALSE}
.endif