aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-05-06 17:55:35 +0800
committertijl <tijl@FreeBSD.org>2014-05-06 17:55:35 +0800
commita97f1b038514c986d185d59aa945c7fd57adbcd9 (patch)
tree1c46666d9cbf619c489cd973d23c31a560d40f89 /Mk
parent09258502e2be3179a61a03a1f42c26cb52f2f3e2 (diff)
downloadfreebsd-ports-gnome-a97f1b038514c986d185d59aa945c7fd57adbcd9.tar.gz
freebsd-ports-gnome-a97f1b038514c986d185d59aa945c7fd57adbcd9.tar.zst
freebsd-ports-gnome-a97f1b038514c986d185d59aa945c7fd57adbcd9.zip
- Run autotools in the same order as autoreconf, i.e. libtoolize, aclocal,
autoconf, autoheader, automake. [1] This should allow replacing custom pre-configure and run-autotools targets that some ports have with USE_AUTOTOOLS. - Set default LIBTOOLIZE_ARGS: -i: install missing build scripts. -c: copy files instead of linking them. This is needed for USES=libtool to be able to patch them. -f: force replacement of existing files. This ensures all files belong to the same version. database/vsqlite: - Fix with new LIBTOOLIZE_ARGS. - INSTALL_TARGET=install-strip. - Drop :keepla. Reported by: Nikola Kolev <koue@chaosophia.net> [1] Exp-run: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.autotools.mk18
1 files changed, 9 insertions, 9 deletions
diff --git a/Mk/bsd.autotools.mk b/Mk/bsd.autotools.mk
index 5fc74c7e1e0c..1c40c70f1ca6 100644
--- a/Mk/bsd.autotools.mk
+++ b/Mk/bsd.autotools.mk
@@ -308,6 +308,8 @@ LIBTOOLFILES?= aclocal.m4
LIBTOOLFILES?= ${CONFIGURE_SCRIPT}
. endif
+LIBTOOLIZE_ARGS?= -i -c -f
+
LIBTOOL_DEPENDS= libtool>=2.4:${PORTSDIR}/${LIBTOOL_PORT}
BUILD_DEPENDS+= ${LIBTOOL_DEPENDS}
.endif
@@ -329,15 +331,13 @@ ${var:tu}_ENV+= ${AUTOTOOLS_VARS}
#---------------------------------------------------------------------------
.if !target(run-autotools)
-.ORDER: run-autotools run-autotools-aclocal \
- patch-autotools-libtool run-autotools-autoheader \
- run-autotools-libtoolize run-autotools-autoconf \
- run-autotools-automake
-
-run-autotools:: run-autotools-aclocal \
- patch-autotools-libtool run-autotools-autoheader \
- run-autotools-libtoolize run-autotools-autoconf \
- run-autotools-automake
+.ORDER: run-autotools run-autotools-libtoolize run-autotools-aclocal \
+ patch-autotools-libtool run-autotools-autoconf \
+ run-autotools-autoheader run-autotools-automake
+
+run-autotools:: run-autotools-libtoolize run-autotools-aclocal \
+ patch-autotools-libtool run-autotools-autoconf \
+ run-autotools-autoheader run-autotools-automake
.endif
.if !target(run-autotools-aclocal)