aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-02-26 00:52:50 +0800
committermiwi <miwi@FreeBSD.org>2011-02-26 00:52:50 +0800
commitafbd9adc91ea20af30292938d6abd193791ae93f (patch)
tree81fd9833ef1b1f53de06c778a19bf1c393d0d703 /Mk
parenta133868afc4cf84dbd611f2791989f867b0fb757 (diff)
downloadfreebsd-ports-gnome-afbd9adc91ea20af30292938d6abd193791ae93f.tar.gz
freebsd-ports-gnome-afbd9adc91ea20af30292938d6abd193791ae93f.tar.zst
freebsd-ports-gnome-afbd9adc91ea20af30292938d6abd193791ae93f.zip
- Please welcome Xorg 7.5.1
The X-Server has been patched to the latest 1.7.X series, drivers and fonts have been updated to the latest versions. This update includes some components from Xorg 7.6 with a lot of improvements, and it seems that the performance is much better than the old version. Also this Update fix build issues with clang and binutils 2.17.50 in current, remove 6.X gruft and de-author pkg-descr. I would like to thank: Beat Gaetzi Dima Panov Koop Mast Eitan Adler and all Testers. PR: ports/147646 ports/148035 ports/148744 ports/150223 ports/152889 ports/154457
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk5
-rw-r--r--Mk/bsd.xorg.mk5
2 files changed, 7 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 36fb761b516e..cd6322830b1e 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1995,7 +1995,10 @@ X_FONTS_TYPE1_PORT= ${PORTSDIR}/x11-fonts/xorg-fonts-type1
X_FONTS_ALIAS_PORT= ${PORTSDIR}/x11-fonts/font-alias
.if defined(USE_IMAKE)
-BUILD_DEPENDS+= imake:${X_IMAKE_PORT}
+CONFIGURE_ENV+= IMAKECPP="${CPP}"
+MAKE_ENV+= IMAKECPP="${CPP}"
+MAKE_FLAGS?= CC="${CC}" CXX="${CXX}"
+BUILD_DEPENDS+= imake:${X_IMAKE_PORT}
.endif
.if defined(USE_DISPLAY) && !defined(DISPLAY)
diff --git a/Mk/bsd.xorg.mk b/Mk/bsd.xorg.mk
index 648dfca84e32..0cf4a2be23d3 100644
--- a/Mk/bsd.xorg.mk
+++ b/Mk/bsd.xorg.mk
@@ -64,6 +64,7 @@ IGNORE= is for sparc64 only
. if ${XORG_CAT} == "font"
FONTDIR?= ${PORTNAME:C/.*-//g:S/type/Type/:S/ttf/TTF/:S/speedo/Speedo/}
+CONFIGURE_ARGS+= --with-fontrootdir=${PREFIX}/lib/X11/fonts
CONFIGURE_ENV+= FONTROOTDIR=${PREFIX}/lib/X11/fonts
NEED_MKFONTFOO= yes
@@ -101,8 +102,8 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
post-install:
. if ${INSTALLS_TTF} == "yes"
. for _fontdir in ${FONTDIR}
- @${ECHO_CMD} "@exec fc-cache -v %D/lib/X11/fonts/${_fontdir} 2>/dev/null || true" >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec fc-cache -v %D/lib/X11/fonts/${_fontdir} 2>/dev/null || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec fc-cache -s %D/lib/X11/fonts/${_fontdir} 2>/dev/null || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec fc-cache -s %D/lib/X11/fonts/${_fontdir} 2>/dev/null || true" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec rmdir %D/lib/X11/fonts/${_fontdir} 2>/dev/null || true" >> ${TMPPLIST}
. endfor
. endif