aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorwosch <wosch@FreeBSD.org>1997-03-10 07:10:56 +0800
committerwosch <wosch@FreeBSD.org>1997-03-10 07:10:56 +0800
commitc42d0a069dbd441dfef0a8d3c9af5e54efe17757 (patch)
treeca834bc19ce18636301173422ef79fb1ef7d6981 /Mk
parentd3430abfbd1d6099463061c926eabe2251e27bab (diff)
downloadfreebsd-ports-gnome-c42d0a069dbd441dfef0a8d3c9af5e54efe17757.tar.gz
freebsd-ports-gnome-c42d0a069dbd441dfef0a8d3c9af5e54efe17757.tar.zst
freebsd-ports-gnome-c42d0a069dbd441dfef0a8d3c9af5e54efe17757.zip
Add comments.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.subdir.mk32
1 files changed, 32 insertions, 0 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index ad3f05bb08c7..09dff44679d3 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -1,5 +1,37 @@
# from: @(#)bsd.subdir.mk 5.9 (Berkeley) 2/1/91
# $Id$
+#
+# The include file <bsd.port.subdir.mk> contains the default targets
+# for building ports subdirectories.
+#
+#
+# +++ variables +++
+#
+# STRIP The flag passed to the install program to cause the binary
+# to be stripped. This is to be used when building your
+# own install script so that the entire system can be made
+# stripped/not-stripped using a single knob. [-s]
+#
+# ECHO_MSG Used to print all the '===>' style prompts - override this
+# to turn them off [echo].
+#
+# OPSYS Get the operating system type [`uname -s`]
+#
+# SUBDIR A list of subdirectories that should be built as well.
+# Each of the targets will execute the same target in the
+# subdirectories.
+#
+#
+# +++ targets +++
+#
+# README.html:
+# Creating README.html for package.
+#
+# afterinstall, all, beforeinstall, build, checksum, clean,
+# configure, depend, describe, extract, fetch, fetch-list,
+# install, package, readmes, realinstall, reinstall, tags
+#
+
.MAIN: all