aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-10-31 13:27:21 +0800
committerdinoex <dinoex@FreeBSD.org>2006-10-31 13:27:21 +0800
commitf1c8830219f4a148184d9e0df3b780eede03997c (patch)
tree31cf428b1664f88ee0fc44f15169f5a2d4aa8cc6 /Mk
parentd6f6af84c0c496ed12422163b2fce4800523632e (diff)
downloadfreebsd-ports-gnome-f1c8830219f4a148184d9e0df3b780eede03997c.tar.gz
freebsd-ports-gnome-f1c8830219f4a148184d9e0df3b780eede03997c.tar.zst
freebsd-ports-gnome-f1c8830219f4a148184d9e0df3b780eede03997c.zip
- new options
USE_GNUSTEP_SYSTEM_APPS= ProjectCenter:devel/projectcenter.app depends on Application installed in System directrory at runtime USE_GNUSTEP_LOCAL_APPS= Ink:misc/gnustep-examples depends on Application installed in Local directrory at runtime USE_GNUSTEP_MAKE_DIRS= App Tools call build and install target in each of the given dirs.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gnustep.mk51
1 files changed, 45 insertions, 6 deletions
diff --git a/Mk/bsd.gnustep.mk b/Mk/bsd.gnustep.mk
index c20e89a90e13..793c00647675 100644
--- a/Mk/bsd.gnustep.mk
+++ b/Mk/bsd.gnustep.mk
@@ -63,16 +63,24 @@
# USE_GNUSTEP_INSTALL=yes
# call install target with GNUstep.sh sourced in the current shell
#
+# USE_GNUSTEP_MAKE_DIRS= App Tools
+# call build and install target in each of the given dirs.
+#
# USE_GNUSTEP_MAKE=yes
# require GNUstep.sh for build and install
#
-# USE_GNUSTEP_SYSTEM_LIBS= Renaissance:x11-toolkits/renaissance
+# USE_GNUSTEP_SYSTEM_LIBS+= Renaissance:x11-toolkits/renaissance
# depends on a shared lib in System directrory
#
-# USE_GNUSTEP_LOCAL_LIBS= pantomime:mail/pantomime
+# USE_GNUSTEP_LOCAL_LIBS+= pantomime:mail/pantomime
# depends on a shared lib in Local directrory
#
-
+# USE_GNUSTEP_SYSTEM_APPS+= ProjectCenter:devel/projectcenter.app
+# depends on Application installed in System directrory at runtime
+#
+# USE_GNUSTEP_LOCAL_APPS+= Ink:misc/gnustep-examples
+# depends on Application installed in Local directrory at runtime
+#
# ---------------------------------------------------------------------------
.if !defined(_POSTMKINCLUDED)
@@ -250,7 +258,7 @@ MAKE_FLAGS+= GUI_BACKEND_LIB=cairo
.endif
# ---------------------------------------------------------------------------
-# source system liibs
+# source system libs
#
.if defined(USE_GNUSTEP_SYSTEM_LIBS)
.for _GNUSTEP_DEP in ${USE_GNUSTEP_SYSTEM_LIBS}
@@ -260,9 +268,8 @@ RUN_DEPENDS+= ${COMBOLIBDIR}/lib${_GNUSTEP_DEP:C/:.*//}.so:${PORTSDIR}/${_GNUSTE
.endif
# ---------------------------------------------------------------------------
-# source local liibs
+# source local libs
#
-:C/[.][0-9]*$//1
.if defined(USE_GNUSTEP_LOCAL_LIBS)
.for _GNUSTEP_DEP in ${USE_GNUSTEP_LOCAL_LIBS}
BUILD_DEPENDS+= ${LOCALLIBDIR}/lib${_GNUSTEP_DEP:C/:.*//}.so:${PORTSDIR}/${_GNUSTEP_DEP:C/.*://}
@@ -271,6 +278,24 @@ RUN_DEPENDS+= ${LOCALLIBDIR}/lib${_GNUSTEP_DEP:C/:.*//}.so:${PORTSDIR}/${_GNUSTE
.endif
# ---------------------------------------------------------------------------
+# source system apps
+#
+.if defined(USE_GNUSTEP_SYSTEM_APPS)
+.for _GNUSTEP_DEP in ${USE_GNUSTEP_SYSTEM_APPS}
+RUN_DEPENDS+= ${SYSTEMDIR}/Applications/${_GNUSTEP_DEP:C/:.*//}.app/${_GNUSTEP_DEP:C/:.*//}:${PORTSDIR}/${_GNUSTEP_DEP:C/.*://}
+.endfor
+.endif
+
+# ---------------------------------------------------------------------------
+# source local apps
+#
+.if defined(USE_GNUSTEP_LOCAL_APPS)
+.for _GNUSTEP_DEP in ${USE_GNUSTEP_LOCAL_APPS}
+RUN_DEPENDS+= ${GNUSTEP_PREFIX}/Local/Applications/${_GNUSTEP_DEP:C/:.*//}.app/${_GNUSTEP_DEP:C/:.*//}:${PORTSDIR}/${_GNUSTEP_DEP:C/.*://}
+.endfor
+.endif
+
+# ---------------------------------------------------------------------------
# source GNUstep.sh
#
.if defined(USE_GNUSTEP_CONFIGURE)
@@ -298,8 +323,15 @@ do-configure:
#
.if defined(USE_GNUSTEP_BUILD)
do-build:
+.if defined(USE_GNUSTEP_MAKE_DIRS)
+.for i in ${USE_GNUSTEP_MAKE_DIRS}
+ @(cd ${WRKSRC}/${i}; . ${SYSMAKEDIR}/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
+.endfor
+.else
@(cd ${WRKSRC}; . ${SYSMAKEDIR}/GNUstep.sh; \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
+.endif
.endif
@@ -308,8 +340,15 @@ do-build:
#
.if defined(USE_GNUSTEP_INSTALL)
do-install:
+.if defined(USE_GNUSTEP_MAKE_DIRS)
+.for i in ${USE_GNUSTEP_MAKE_DIRS}
+ @(cd ${WRKSRC}/${i}; . ${SYSMAKEDIR}/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
+.endfor
+.else
@(cd ${WRKSRC}; . ${SYSMAKEDIR}/GNUstep.sh; \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(BATCH) || defined(CLEAN_ROOT)
rm -rf /root/GNUstep
.endif