aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-06-23 05:44:39 +0800
committerbapt <bapt@FreeBSD.org>2015-06-23 05:44:39 +0800
commitf237b101cfca84b1d4ed6fa12e508187fd9636f0 (patch)
tree48ce215e3893bab7507cb645faf688f1f2b11165 /Mk
parent51eee8656c8d5d88102199a98e67e41f5f0979b9 (diff)
downloadfreebsd-ports-gnome-f237b101cfca84b1d4ed6fa12e508187fd9636f0.tar.gz
freebsd-ports-gnome-f237b101cfca84b1d4ed6fa12e508187fd9636f0.tar.zst
freebsd-ports-gnome-f237b101cfca84b1d4ed6fa12e508187fd9636f0.zip
Factorize the fake for convenience targets
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk11
1 files changed, 4 insertions, 7 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 0b0ce9efc2dc..b112e98b657e 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -5254,15 +5254,12 @@ fake-pkg: create-manifest
# Depend is generally meaningless for arbitrary ports, but if someone wants
# one they can override this. This is just to catch people who've gotten into
# the habit of typing `make depend all install' as a matter of course.
-#
-.if !target(depend)
-depend:
-.endif
-
# Same goes for tags
-.if !target(tags)
-tags:
+.for _t in depend tags
+.if !target(${_t})
+${_t}:
.endif
+.endfor
.if !defined(NOPRECIOUSMAKEVARS)
# These won't change, so we can pass them through the environment