aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2011-11-07 05:55:53 +0800
committerohauer <ohauer@FreeBSD.org>2011-11-07 05:55:53 +0800
commit3591fe8142278d67353cfdf6ee60f220547b6397 (patch)
tree7555926e4dc975d90b6f1946930b788eb66a49ce /Mk
parente0e1331c7ede52f91d8aba429e2efac1bc4ef501 (diff)
downloadfreebsd-ports-gnome-3591fe8142278d67353cfdf6ee60f220547b6397.tar.gz
freebsd-ports-gnome-3591fe8142278d67353cfdf6ee60f220547b6397.tar.zst
freebsd-ports-gnome-3591fe8142278d67353cfdf6ee60f220547b6397.zip
- force usage of USE_APACHE values without '.'
Examples: USE_APACHE= 22 # specify exact version USE_APACHE= 13+ # specify [min] version, no [max] version USE_APACHE= 13-22 # specify [min]-[max] range USE_APACHE= -22 # specify [max] version, no [min] version with hat apache@
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.apache.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/bsd.apache.mk b/Mk/bsd.apache.mk
index e6002539cdcb..928e27e40e44 100644
--- a/Mk/bsd.apache.mk
+++ b/Mk/bsd.apache.mk
@@ -97,9 +97,9 @@ _ERROR_MSG= : Error from bsd.apache.mk.
.if defined(USE_APACHE) && !empty(USE_APACHE)
. if ${USE_APACHE:Mcommon*} != ""
AP_PORT_IS_SERVER= YES
-. elif ${USE_APACHE:C/\.//g:C/\-//:S/^13//:S/^20//:S/^22//:C/\+$//} == ""
+. elif ${USE_APACHE:C/\-//:S/^13//:S/^20//:S/^22//:C/\+$//} == ""
AP_PORT_IS_MODULE= YES
-. if ${USE_APACHE:C/\.//g:C/\-//:S/^13//:S/^20//:S/^22//} == "+"
+. if ${USE_APACHE:C/\-//:S/^13//:S/^20//:S/^22//} == "+"
AP_PLUS= yes
. endif
. else
@@ -440,7 +440,7 @@ AP_EXTRAS+= -L ${AP_LIB}
Apache_Post_Include= bsd.apache.mk
.if defined(USE_APACHE_RUN) && !empty(USE_APACHE_RUN)
-. if ${USE_APACHE_RUN:C/\.//g:C/\-//:S/^13//:S/^20//:S/^22//:C/\+$//} != ""
+. if ${USE_APACHE_RUN:C/\-//:S/^13//:S/^20//:S/^22//:C/\+$//} != ""
IGNORE= ${_ERROR_MSG} Illegal use of USE_APACHE_RUN ( ${USE_APACHE_RUN} )
. endif
.elif defined(USE_APACHE_RUN)
@@ -448,7 +448,7 @@ IGNORE= ${_ERROR_MSG} Illegal use of USE_APACHE_RUN ( no valid version specified
.endif
.if defined(USE_APACHE_BUILD) && !empty(USE_APACHE_BUILD)
-. if ${USE_APACHE_BUILD:C/\.//g:C/\-//:S/^13//:S/^20//:S/^22//:C/\+$//} != ""
+. if ${USE_APACHE_BUILD:C/\-//:S/^13//:S/^20//:S/^22//:C/\+$//} != ""
IGNORE= ${_ERROR_MSG} Illegal use of USE_APACHE_BUILD ( ${USE_APACHE_BUILD} )
. endif
.elif defined(USE_APACHE_BUILD)