aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-08-21 21:05:20 +0800
committermat <mat@FreeBSD.org>2015-08-21 21:05:20 +0800
commitbfbc37cac841518751aad658882af626e0425406 (patch)
treef5d6921aded58004606c06ebde09012c69e1af70 /Mk
parente6a132162a3e25404fd9f079a9bc36995a96544d (diff)
downloadfreebsd-ports-gnome-bfbc37cac841518751aad658882af626e0425406.tar.gz
freebsd-ports-gnome-bfbc37cac841518751aad658882af626e0425406.tar.zst
freebsd-ports-gnome-bfbc37cac841518751aad658882af626e0425406.zip
Fix with fmake.
Noticed by: marck Sponsored by: Absolight
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.options.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index d1359f330343..1a4f111b4c6f 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -384,7 +384,8 @@ _DEPCHAIN+= ${opt}.$o
## All of RHS of "RHS.*" (i.e. indirect dependency) are also added for
## fast convergence.
_PORT_OPTIONS:= ${PORT_OPTIONS}
-.for count in _0 ${COMPLETE_OPTIONS_LIST}
+.for _count in _0 ${COMPLETE_OPTIONS_LIST}
+count= ${_count}
### Check if all of the nested dependency are resolved already.
. if ${count} == _0 || ${_PORT_OPTIONS} != ${PORT_OPTIONS}
PORT_OPTIONS:= ${_PORT_OPTIONS}