aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-09-22 18:48:28 +0800
committermat <mat@FreeBSD.org>2017-09-22 18:48:28 +0800
commitd9b3f2d70221e2edb53316d0af198504f8090ae1 (patch)
tree5ec4d6c8c02d380cf421717b2ce88beceb851e79 /Mk
parent82267b98f1fc7e9ab7316d3d76128cd4a197c04d (diff)
downloadfreebsd-ports-gnome-d9b3f2d70221e2edb53316d0af198504f8090ae1.tar.gz
freebsd-ports-gnome-d9b3f2d70221e2edb53316d0af198504f8090ae1.tar.zst
freebsd-ports-gnome-d9b3f2d70221e2edb53316d0af198504f8090ae1.zip
Remove USES=execinfo.
PR: 220271 Submitted by: mat (review), Yasuhiro KIMURA (PR) Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D11488
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Scripts/qa.sh3
-rw-r--r--Mk/Uses/execinfo.mk27
2 files changed, 0 insertions, 30 deletions
diff --git a/Mk/Scripts/qa.sh b/Mk/Scripts/qa.sh
index be506eab162f..3ef3c7ee11fb 100644
--- a/Mk/Scripts/qa.sh
+++ b/Mk/Scripts/qa.sh
@@ -585,9 +585,6 @@ proxydeps_suggest_uses() {
# bdb
elif expr ${pkg} : "^databases/db[456]" > /dev/null; then
warn "you need USES+=bdb"
- # execinfo
- elif [ ${pkg} = "devel/libexecinfo" ]; then
- warn "you need USES+=execinfo"
# fam/gamin
elif [ ${pkg} = "devel/fam" -o ${pkg} = "devel/gamin" ]; then
warn "you need USES+=fam"
diff --git a/Mk/Uses/execinfo.mk b/Mk/Uses/execinfo.mk
deleted file mode 100644
index d185dc01e262..000000000000
--- a/Mk/Uses/execinfo.mk
+++ /dev/null
@@ -1,27 +0,0 @@
-# $FreeBSD$
-#
-# handle dependency on libexecinfo
-#
-# Feature: execinfo
-# Usage: USES=execinfo
-#
-# Takes no arguments
-#
-# Exported variables:
-#
-# EXECINFO_CPPFLAGS - preprocessor flags needed to correctly use
-# execinfo library
-# EXECINFO_LDFLAGS - linker flags needed to correctly use
-# execinfo library
-#
-
-.if !defined(_INCLUDE_USES_EXECINFO_MK)
-_INCLUDE_USES_EXECINFO_MK= yes
-
-.if !exists(/usr/lib/libexecinfo.so)
-LIB_DEPENDS+= libexecinfo.so:devel/libexecinfo
-EXECINFO_CPPFLAGS= -I${LOCALBASE}/include
-EXECINFO_LDFLAGS= -L${LOCALBASE}/lib
-.endif
-
-.endif