aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-01-04 08:26:03 +0800
committerbapt <bapt@FreeBSD.org>2014-01-04 08:26:03 +0800
commit06d803a7e88c84f3a6c0088cb35b9bbbaa77d2fd (patch)
treeaada2bfd942cd5069f49a8d3c646ded474db68d4 /Mk
parent7352f6a13f551291a39ac272a0d52e7b98c47b00 (diff)
downloadfreebsd-ports-gnome-06d803a7e88c84f3a6c0088cb35b9bbbaa77d2fd.tar.gz
freebsd-ports-gnome-06d803a7e88c84f3a6c0088cb35b9bbbaa77d2fd.tar.zst
freebsd-ports-gnome-06d803a7e88c84f3a6c0088cb35b9bbbaa77d2fd.zip
Properly add targets to the sequence they belong to, that now makes them predictable
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/desktop-file-utils.mk4
-rw-r--r--Mk/Uses/dos2unix.mk3
-rw-r--r--Mk/Uses/kmod.mk2
-rw-r--r--Mk/Uses/shared-mime-info.mk4
-rw-r--r--Mk/Uses/shebangfix.mk3
-rw-r--r--Mk/Uses/webplugin.mk3
-rw-r--r--Mk/bsd.port.mk9
7 files changed, 6 insertions, 22 deletions
diff --git a/Mk/Uses/desktop-file-utils.mk b/Mk/Uses/desktop-file-utils.mk
index 92ff6b1fcc1f..386769ec0e23 100644
--- a/Mk/Uses/desktop-file-utils.mk
+++ b/Mk/Uses/desktop-file-utils.mk
@@ -19,10 +19,6 @@ IGNORE= USES=desktop-file-utils does not require args
BUILD_DEPENDS+= update-desktop-database:${PORTSDIR}/devel/desktop-file-utils
RUN_DEPENDS+= update-desktop-database:${PORTSDIR}/devel/desktop-file-utils
-# bolt our post-install target to post-install
-.PHONY: desktop-file-post-install
-post-install: desktop-file-post-install
-
desktop-file-post-install:
.if defined(NO_STAGE)
# run for port post-install
diff --git a/Mk/Uses/dos2unix.mk b/Mk/Uses/dos2unix.mk
index dca6d681f9f0..6abc251a921f 100644
--- a/Mk/Uses/dos2unix.mk
+++ b/Mk/Uses/dos2unix.mk
@@ -15,9 +15,6 @@ _INCLUDE_USES_DOS2UNIX_MK= yes
_DOS2UNIX_ALL= yes
.endif
-.PHONY: dos2unix
-pre-patch: dos2unix
-
dos2unix:
@${ECHO_MSG} "===> Converting DOS text files to UNIX text files"
.if defined(_DOS2UNIX_ALL)
diff --git a/Mk/Uses/kmod.mk b/Mk/Uses/kmod.mk
index 4932b47ad1b7..daf1b58222ae 100644
--- a/Mk/Uses/kmod.mk
+++ b/Mk/Uses/kmod.mk
@@ -40,12 +40,10 @@ MAKE_ENV+= NO_XREF=yes
.if defined(_POSTMKINCLUDED) && !defined(_INCLUDE_USES_KMOD_POST_MK)
_INCLUDE_USES_KMOD_POST_MK= yes
-.PHONY: kmod-post-install
pre-install: ${STAGEDIR}${KMODDIR}
${STAGEDIR}${KMODDIR}:
@${MKDIR} ${.TARGET}
-post-install: kmod-post-install
kmod-post-install:
@${ECHO_CMD} "@exec /usr/sbin/kldxref ${KMODDIR}" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec /usr/sbin/kldxref ${KMODDIR}" >> ${TMPPLIST}
diff --git a/Mk/Uses/shared-mime-info.mk b/Mk/Uses/shared-mime-info.mk
index cb4c62ea4e41..daed45c414f9 100644
--- a/Mk/Uses/shared-mime-info.mk
+++ b/Mk/Uses/shared-mime-info.mk
@@ -19,10 +19,6 @@ IGNORE= USES=shared-mime-info does not require args
BUILD_DEPENDS+= update-mime-database:${PORTSDIR}/misc/shared-mime-info
RUN_DEPENDS+= update-mime-database:${PORTSDIR}/misc/shared-mime-info
-# bolt our post-install target to post-install
-.PHONY: shared-mime-post-install
-post-install: shared-mime-post-install
-
shared-mime-post-install:
.if defined(NO_STAGE)
# run for port post-install
diff --git a/Mk/Uses/shebangfix.mk b/Mk/Uses/shebangfix.mk
index ee198aa9d383..f125cef82410 100644
--- a/Mk/Uses/shebangfix.mk
+++ b/Mk/Uses/shebangfix.mk
@@ -53,9 +53,6 @@ IGNORE+= missing definition for ${lang}_OLD_CMD
_SHEBANG_REINPLACE_ARGS+= -e "1s|^\#![[:space:]]*${${lang}_OLD_CMD}|\#!${${lang}_CMD}|"
.endfor
-.PHONY: fix-shebang
-pre-patch: fix-shebang
-
fix-shebang:
@cd ${WRKSRC}; \
${ECHO_CMD} ${SHEBANG_FILES} | ${XARGS} ${SED} -i '' ${_SHEBANG_REINPLACE_ARGS}
diff --git a/Mk/Uses/webplugin.mk b/Mk/Uses/webplugin.mk
index 52669970b0fe..f681c3b1c5d9 100644
--- a/Mk/Uses/webplugin.mk
+++ b/Mk/Uses/webplugin.mk
@@ -166,7 +166,6 @@ WEBPLUGIN_DIR?= ${_WEBPLUGIN_LIBDIR:S,^${LOCALBASE}/,${PREFIX}/,}/${WEBPLUGIN_N
PLIST_SUB+= WEBPLUGIN_DIR="${WEBPLUGIN_DIR:S,^${PREFIX}/,,}"
-.PHONY: webplugin-post-install
webplugin-post-install:
@${ECHO_CMD} "@cwd ${LOCALBASE}" >> ${TMPPLIST}
.for d in ${_WEBPLUGIN_LINKFARMS}
@@ -180,6 +179,4 @@ webplugin-post-install:
@${ECHO_CMD} "@unexec rmdir ${_WEBPLUGIN_SLDIR:S,^${LOCALBASE},%D,} 2>/dev/null || true" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec rmdir ${_WEBPLUGIN_LIBDIR:S,^${LOCALBASE},%D,} 2>/dev/null || true" >> ${TMPPLIST}
-post-install: webplugin-post-install
-
.endif
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a8abd016ec68..36a3404a9113 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -6474,7 +6474,8 @@ _EXTRACT_SEQ= check-build-conflicts extract-message checksum extract-depends \
pre-extract pre-extract-script do-extract \
post-extract post-extract-script
_PATCH_DEP= extract
-_PATCH_SEQ= ask-license patch-message patch-depends pathfix-pre-patch pre-patch \
+_PATCH_SEQ= ask-license patch-message patch-depends pathfix-pre-patch dos2unix fix-shebang \
+ pre-patch \
pre-patch-script do-patch charsetfix-post-patch post-patch post-patch-script
_CONFIGURE_DEP= patch
_CONFIGURE_SEQ= build-depends lib-depends configure-message run-autotools-fixup \
@@ -6497,8 +6498,9 @@ _STAGE_SUSEQ= create-users-groups do-install post-install post-install-script po
_STAGE_SUSEQ+= stage-qa
.endif
.else
-_STAGE_SEQ+= create-users-groups do-install post-install post-install-script post-stage compress-man \
- install-rc-script install-ldconfig-file install-license \
+_STAGE_SEQ+= create-users-groups do-install desktop-file-post-install kmod-post-install \
+ shared-mime-post-install webplugin-post-install post-install post-install-script \
+ post-stage compress-man install-rc-script install-ldconfig-file install-license \
install-desktop-entries add-plist-info add-plist-docs add-plist-examples \
add-plist-data add-plist-post fix-plist-sequence
.if defined(DEVELOPER)
@@ -6531,6 +6533,7 @@ _INSTALL_SEQ= install-message check-install-conflicts run-depends lib-depends ap
_INSTALL_SUSEQ= check-umask install-mtree pre-su-install \
pre-su-install-script create-users-groups do-install \
install-desktop-entries install-license install-rc-script \
+ desktop-file-post-install kmod-post-install shared-mime-post-install webplugin-post-install \
post-install post-install-script add-plist-buildinfo \
add-plist-info add-plist-docs add-plist-examples \
add-plist-data add-plist-post fix-plist-sequence \