aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-09-27 01:44:08 +0800
committerrakuco <rakuco@FreeBSD.org>2016-09-27 01:44:08 +0800
commit3576377cd2e454f7d7e4fb962bc4edaaf0d866fa (patch)
tree4df6e08ccc34ff76ace8023f6326c889c2442ba4 /Mk
parentfb5ca509f8a9b6a4488d15c7267e87ed598a760b (diff)
downloadfreebsd-ports-gnome-3576377cd2e454f7d7e4fb962bc4edaaf0d866fa.tar.gz
freebsd-ports-gnome-3576377cd2e454f7d7e4fb962bc4edaaf0d866fa.tar.zst
freebsd-ports-gnome-3576377cd2e454f7d7e4fb962bc4edaaf0d866fa.zip
bsd.qt.mk: Use CONFIGURE_WRKSRC instead of WRKSRC in the .qmake.cache hack
WRKSRC is not what we want here: when USES=qmake:outsource is used (such as in www/webkit-qt5), the build actually takes place in ${WRKDIR}/.build, so we were creating .qmake.cache in the wrong location and passing the wrong directory to the linker via -L. With CONFIGURE_WRKSRC, we get the right value regardless of whether :outsource is used or not. PR: 212859 Reviewed by: tcberner MFH: 2016Q3
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.qt.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index 543ad3988dfe..93756bd19056 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -654,7 +654,8 @@ qt5-pre-configure:
# Since we cannot extract tests/auto/cmake/ and exclude tests/ at the same
# time, we have to disable the check in a cache file (the only way to get this
# value through to the configure script in qtbase).
- ${ECHO_CMD} 'CMAKE_MODULE_TESTS = -' > ${WRKSRC}/.qmake.cache
+ ${MKDIR} ${CONFIGURE_WRKSRC}
+ ${ECHO_CMD} 'CMAKE_MODULE_TESTS = -' > ${CONFIGURE_WRKSRC}/.qmake.cache
# We piggyback on QMAKE_LIBDIR_FLAGS to make sure -L${WRKSRC}/lib is passed to
# the linker before -L/usr/local/lib. By default, the opposite happens, which
# is a problem when a Qt port is being upgraded, since an existing library
@@ -663,7 +664,7 @@ qt5-pre-configure:
# latter to get the linker path order right. qmake is smart enough to strip
# occurrences of ${WRKSRC}/lib from .pc and .prl files when installing them.
# See QTBUG-40825 and ports bugs 194088, 195105 and 198720.
- ${ECHO_CMD} 'QMAKE_LIBDIR_FLAGS = -L${WRKSRC}/lib' >> ${WRKSRC}/.qmake.cache
+ ${ECHO_CMD} 'QMAKE_LIBDIR_FLAGS = -L${CONFIGURE_WRKSRC}/lib' >> ${CONFIGURE_WRKSRC}/.qmake.cache
pre-install: qt-pre-install
qt-pre-install: