aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2012-12-14 23:47:00 +0800
committerflo <flo@FreeBSD.org>2012-12-14 23:47:00 +0800
commit58aa2f3afdfbed9633415c78da1aca4b56f98ea1 (patch)
tree2f5c5fe4cb36fc6a28856c97750108bf78f9b5b4 /Mk
parent7ac66068799630167ca6ef9dfb761d82590bd787 (diff)
downloadfreebsd-ports-gnome-58aa2f3afdfbed9633415c78da1aca4b56f98ea1.tar.gz
freebsd-ports-gnome-58aa2f3afdfbed9633415c78da1aca4b56f98ea1.tar.zst
freebsd-ports-gnome-58aa2f3afdfbed9633415c78da1aca4b56f98ea1.zip
- introduce a USE_FUSE macro
- convert all fuse ports to use the new macro The macro makes sure sysutils/fusefs-libs gets installed and depending on fuse being in base or not it installs sysutils/fusefs-kmod. Approved by: portmgr (bapt)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 67ed5b3c79f3..c48cb284f5f7 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -408,6 +408,9 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# - Legal values are: gamin (default),fam
# If set to an unknown value, the port is marked IGNORE.
##
+# USE_FUSE - If set, make sure necessary components unavailable in base
+# are installed from ports.
+##
# USE_AUTOTOOLS - If set, this port uses various GNU autotools
# (libtool, autoconf, autoheader, automake et al.)
# See bsd.autotools.mk for more details.
@@ -1833,6 +1836,13 @@ IGNORE= cannot be built with unknown FAM system: ${FAM_SYSTEM}
.endif
.endif # USE_FAM
+.if defined(USE_FUSE)
+LIB_DEPENDS+= fuse:${PORTSDIR}/sysutils/fusefs-libs
+.if !exists(/sbin/mount_fusefs)
+RUN_DEPENDS+= mount_fusefs:${PORTSDIR}/sysutils/fusefs-kmod
+.endif
+.endif
+
.if defined(USE_RC_SUBR) && ${USE_RC_SUBR:U} != "YES"
SUB_FILES+= ${USE_RC_SUBR}
.endif