aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2016-08-17 23:42:23 +0800
committerdbn <dbn@FreeBSD.org>2016-08-17 23:42:23 +0800
commit5eb1e5a3ed8199ca8c11e03f84b098cfecde3544 (patch)
treeb3230066801a393467d686fd1ce286f69fb286ca /Mk
parentd1463880348626261fe105a3dd601dffd07d14f7 (diff)
downloadfreebsd-ports-gnome-5eb1e5a3ed8199ca8c11e03f84b098cfecde3544.tar.gz
freebsd-ports-gnome-5eb1e5a3ed8199ca8c11e03f84b098cfecde3544.tar.zst
freebsd-ports-gnome-5eb1e5a3ed8199ca8c11e03f84b098cfecde3544.zip
Mk/Uses/cran.mk: fix 'compiles' argument.
Due to the change in r419666 USE_GCC is not conditionally set, however it was bringing in the dependencies for fortran (silently). Explicitly bring in the dependencies for fortran. Also, add a target to strip the compiled shared library. PR: 211891 Reviewed by: mat Approved by: wen
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/cran.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/Mk/Uses/cran.mk b/Mk/Uses/cran.mk
index b63d76c73489..fb2cd56e2f98 100644
--- a/Mk/Uses/cran.mk
+++ b/Mk/Uses/cran.mk
@@ -78,7 +78,11 @@ cran-auto-plist:
.endif
.if ${cran_ARGS:Mcompiles}
+_USES_install+= 755:cran-strip
+cran-strip:
+ ${FIND} ${STAGEDIR}${PREFIX}/${R_MOD_DIR} -name '*.so' -exec ${STRIP_CMD} {} +
.include "${PORTSDIR}/math/R/compiler.mk"
+.include "${USESDIR}/fortran.mk"
.endif
.endif #_INCLUDE_USES_CRAN_MK