aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2017-02-18 06:22:27 +0800
committerbdrewery <bdrewery@FreeBSD.org>2017-02-18 06:22:27 +0800
commit6a6abf0a465efccd963a1700cf6115a10c88c751 (patch)
tree9bc87eff13638af16181a6b1bd379a86957c397b /Mk
parente4a90ce1226d399b1b84c86252745d509cbc6257 (diff)
downloadfreebsd-ports-gnome-6a6abf0a465efccd963a1700cf6115a10c88c751.tar.gz
freebsd-ports-gnome-6a6abf0a465efccd963a1700cf6115a10c88c751.tar.zst
freebsd-ports-gnome-6a6abf0a465efccd963a1700cf6115a10c88c751.zip
ports_env: Fix OPSYS not being exported.
This was causing excessive 'uname -s' executions during Poudriere dependency calculations. The reasoning is due to HAVE_COMPAT_IA32_KERN having a newline quoted at the end of it as '\ ' by bmake: # make -f Mk/bsd.port.mk -V 'HAVE_COMPAT_IA32_KERN=${HAVE_COMPAT_IA32_KERN:Q}' | cat -v HAVE_COMPAT_IA32_KERN=YES\ This resulted in the following being executed: export HAVE_COMPAT_IA32_KERN="YES OPSYS=FreeBSD" With hat: portmgr
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Scripts/functions.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Scripts/functions.sh b/Mk/Scripts/functions.sh
index 24bfd5544de0..5122a8abaae9 100644
--- a/Mk/Scripts/functions.sh
+++ b/Mk/Scripts/functions.sh
@@ -202,7 +202,7 @@ export_ports_env() {
# Bring in all the vars, but not empty ones.
eval $(${MAKE} -f ${PORTSDIR}/Mk/bsd.port.mk ${make_cmd} \
- USES="${uses}" | grep -v '=$')
+ USES="${uses}" | grep -v '=$' | sed -e 's,\\ $,,')
for var in ${export_vars}; do
# Export and display non-empty ones. This is not redundant
# with above since we're looping on all vars here; do not