aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-03-13 22:42:59 +0800
committerjbeich <jbeich@FreeBSD.org>2016-03-13 22:42:59 +0800
commit7f698c42d8f2559f9fbb33265cc301aee5f0658f (patch)
tree53628d49ea3a854b71feb4516725b9ddd624ceb5 /Mk
parent09d5a1cc0117ab4e10a620f8865cb07d6e52dda8 (diff)
downloadfreebsd-ports-gnome-7f698c42d8f2559f9fbb33265cc301aee5f0658f.tar.gz
freebsd-ports-gnome-7f698c42d8f2559f9fbb33265cc301aee5f0658f.tar.zst
freebsd-ports-gnome-7f698c42d8f2559f9fbb33265cc301aee5f0658f.zip
www/firefox: work around Clang 3.4 crash with OPTIMIZED_CFLAGS=off
Pretend we want C++14 to pull more modern version of Clang on 10.x i386. PR: 207837 MFH: 2016Q1
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gecko.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 3a9f26157eed..26bed2d2a5d0 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -304,6 +304,9 @@ CFLAGS+= -O3
MOZ_EXPORT+= MOZ_OPTIMIZE_FLAGS="${CFLAGS:M-O*}"
MOZ_OPTIONS+= --enable-optimize
.else
+. if ${MOZILLA_VER:R:R} >= 45 && ${OSREL:R} == 10 && ${ARCH} == i386
+USES:= compiler:c++14-lang ${USES:Ncompiler*c++11*} # XXX ports/207837
+. endif
MOZ_OPTIONS+= --disable-optimize
.endif