aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorgpalmer <gpalmer@FreeBSD.org>1994-12-11 22:50:40 +0800
committergpalmer <gpalmer@FreeBSD.org>1994-12-11 22:50:40 +0800
commit98ecc176c1c37c40efddae39651bb84e0e03faa0 (patch)
treedacc502e5d83649ebbd6723ca84fcee5c710dee7 /Mk
parent62ca41ab9afa1a004444e72468629a71d6ef2ebe (diff)
downloadfreebsd-ports-gnome-98ecc176c1c37c40efddae39651bb84e0e03faa0.tar.gz
freebsd-ports-gnome-98ecc176c1c37c40efddae39651bb84e0e03faa0.tar.zst
freebsd-ports-gnome-98ecc176c1c37c40efddae39651bb84e0e03faa0.zip
<Sigh> Got the placing of a .if wrong. Fix it.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 1314f8b60c1a..542900c0e814 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.75 1994/12/10 18:07:38 gpalmer Exp $
+# $Id: bsd.port.mk,v 1.76 1994/12/11 14:12:30 gpalmer Exp $
#
# Please view me with 4 column tabs!
@@ -365,15 +365,17 @@ pre-patch:
patch: pre-patch ${PATCH_COOKIE}
${PATCH_COOKIE}:
- @if [ -d ${PATCHDIR} ]; then \
.if defined(PATCH_DEBUG)
+ @if [ -d ${PATCHDIR} ]; then \
echo "===> Applying patches for ${DISTNAME}" ; \
- for i in ${PATCHDIR}/patch-*; \
+ for i in ${PATCHDIR}/patch-*; do \
echo "===> Applying patch $$i" ; \
- do ${PATCH} ${PATCH_ARGS} < $$i; \
+ ${PATCH} ${PATCH_ARGS} < $$i; \
done; \
fi
+ @${TOUCH} ${TOUCH_FLAGS} ${PATCH_COOKIE}
.else
+ @if [ -d ${PATCHDIR} ]; then \
echo "===> Applying patches for ${DISTNAME}" ; \
for i in ${PATCHDIR}/patch-*; \
do ${PATCH} {$PATCH_ARGS} < $$i; \