aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-05-12 01:35:18 +0800
committerpav <pav@FreeBSD.org>2009-05-12 01:35:18 +0800
commitb3d0157d12cbeeeba3a7dd174da6e2dfa0e15944 (patch)
treed219c93bb9919233eb8501bc3664ad1bf84d3a20 /Mk
parentacecad311052119eb8900caa53344aa1d135cc2a (diff)
downloadfreebsd-ports-gnome-b3d0157d12cbeeeba3a7dd174da6e2dfa0e15944.tar.gz
freebsd-ports-gnome-b3d0157d12cbeeeba3a7dd174da6e2dfa0e15944.tar.zst
freebsd-ports-gnome-b3d0157d12cbeeeba3a7dd174da6e2dfa0e15944.zip
- Add a code to drop bsd.port.options.mk into /usr/share/mk if it's missing on
the system (typically FreeBSD prior to 6.3). Allows to continue if the write fails. This should allow us to start using it widely in the ports tree (please not just yet, wait for a heads-up, in case this change needs to be backed out.)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 5558ab6cee96..4bd52e0ef5b9 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -2816,6 +2816,19 @@ maintainer:
.if !target(check-makefile)
check-makefile::
+.if !exists(/usr/share/mk/bsd.port.options.mk)
+ @${ECHO_CMD} "!!! Detected system without bsd.port.options.mk (probably old FreeBSD version)"
+ @${ECHO_CMD} "!!! Dropping bsd.port.options.mk into /usr/share/mk"
+ -@${ECHO_CMD} "USEOPTIONSMK= yes" > /usr/share/mk/bsd.port.options.mk 2>/dev/null
+ -@${ECHO_CMD} "INOPTIONSMK= yes" >> /usr/share/mk/bsd.port.options.mk 2>/dev/null
+ -@${ECHO_CMD} ".include <bsd.port.mk>" >> /usr/share/mk/bsd.port.options.mk 2>/dev/null
+ -@${ECHO_CMD} ".undef INOPTIONSMK" >> /usr/share/mk/bsd.port.options.mk 2>/dev/null
+.if exists(/usr/share/mk/bsd.port.options.mk)
+ @${ECHO_CMD} "!!! Done"
+.else
+ @${ECHO_CMD} "!!! Failed"
+.endif
+.endif
@${DO_NADA}
.endif