aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-06-02 16:48:13 +0800
committermat <mat@FreeBSD.org>2014-06-02 16:48:13 +0800
commitbc87e85976806565b38d0ed29318d5e4463aa961 (patch)
treed1be9af7143a2115dab147a89be529abf1dba49e /Mk
parentb000c9e9e71c8df3f633fba46b91ca22046b0e34 (diff)
downloadfreebsd-ports-gnome-bc87e85976806565b38d0ed29318d5e4463aa961.tar.gz
freebsd-ports-gnome-bc87e85976806565b38d0ed29318d5e4463aa961.tar.zst
freebsd-ports-gnome-bc87e85976806565b38d0ed29318d5e4463aa961.zip
Apply a band-aid on Perl ports plists for perl 5.20.
This is not the right fix, but with this, we can move forward. With hat: perl@, portmgr Sponsored by: Absolight
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/perl5.mk5
-rw-r--r--Mk/bsd.port.mk6
2 files changed, 8 insertions, 3 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index 73860e4a1bfe..471cb2642e7b 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -265,6 +265,11 @@ fix-packlist::
-@[ -d ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}/auto ] && ${FIND} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}/auto -name .packlist -exec ${SED} -i '' 's|^${STAGEDIR}||' '{}' \;
.endif
+.if ${PERL_LEVEL} >= 502000
+fix-plist-perl:
+ -@${REINPLACE_CMD} '/\.bs$$/d' ${TMPPLIST}
+.endif
+
.if !target(regression-test)
TEST_ARGS+= ${MAKE_ARGS}
TEST_ENV+= ${MAKE_ENV}
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a062b108cbe0..f36d1c2b2b4b 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -6523,7 +6523,7 @@ _STAGE_SUSEQ= create-users-groups do-install \
install-rc-script install-ldconfig-file install-license \
install-desktop-entries add-plist-info add-plist-docs \
add-plist-examples add-plist-data add-plist-post \
- move-uniquefiles-plist fix-plist-sequence fix-packlist
+ move-uniquefiles-plist fix-plist-sequence fix-packlist fix-plist-perl
.if defined(DEVELOPER)
_STAGE_SUSEQ+= stage-qa
.endif
@@ -6536,7 +6536,7 @@ _STAGE_SEQ+= create-users-groups do-install \
install-rc-script install-ldconfig-file install-license \
install-desktop-entries add-plist-info add-plist-docs \
add-plist-examples add-plist-data add-plist-post \
- move-uniquefiles-plist fix-plist-sequence fix-packlist
+ move-uniquefiles-plist fix-plist-sequence fix-packlist fix-plist-perl
.if defined(DEVELOPER)
_STAGE_SEQ+= stage-qa
.endif
@@ -6570,7 +6570,7 @@ _INSTALL_SUSEQ= check-umask install-mtree pre-su-install \
desktop-file-post-install kmod-post-install shared-mime-post-install webplugin-post-install \
post-install post-install-script add-plist-buildinfo \
add-plist-info add-plist-docs add-plist-examples \
- add-plist-data add-plist-post fix-plist-sequence \
+ add-plist-data add-plist-post fix-plist-sequence fix-plist-perl \
compress-man install-ldconfig-file fake-pkg security-check
_PACKAGE_DEP= install
_PACKAGE_SEQ= package-message pre-package pre-package-script \