aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authoremaste <emaste@FreeBSD.org>2018-09-18 22:48:48 +0800
committeremaste <emaste@FreeBSD.org>2018-09-18 22:48:48 +0800
commitc6642a2b35784ad5607a7e84e7844d4baba43c49 (patch)
treeeb714b6159c7c511c1f29417bdc1398e0953e472 /Mk
parent3ee7e3fa3a1402cb814e3c20cfd9f8b54a3c072f (diff)
downloadfreebsd-ports-gnome-c6642a2b35784ad5607a7e84e7844d4baba43c49.tar.gz
freebsd-ports-gnome-c6642a2b35784ad5607a7e84e7844d4baba43c49.tar.zst
freebsd-ports-gnome-c6642a2b35784ad5607a7e84e7844d4baba43c49.zip
Hoist LDFLAGS_${ARCH} logic into bsd.port.mk
Approved by: portmgr (bapt) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 688a38c2cdd2..c8e1008a5c81 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -363,6 +363,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# CXXFLAGS_${ARCH}
# Append the cxxflags to CXXFLAGS only on the specified architecture
##
+# LDFLAGS_${ARCH} Append the ldflags to LDFLAGS only on the specified architecture
# USE_SDL - If set, this port uses the sdl libraries.
# See bsd.sdl.mk for more information.
##
@@ -2050,6 +2051,10 @@ ${lang}FLAGS+= ${${lang}FLAGS_${ARCH}}
.endif
.endfor
+.if defined(LDFLAGS_${ARCH})
+LDFLAGS+= ${LDFLAGS_${ARCH}}
+.endif
+
# Multiple make jobs support
.if defined(DISABLE_MAKE_JOBS) || defined(MAKE_JOBS_UNSAFE)
_MAKE_JOBS?= #