aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-07-18 19:13:02 +0800
committermat <mat@FreeBSD.org>2018-07-18 19:13:02 +0800
commitc74a78b56a0693244bc0e28895aa5aa6fda6cc85 (patch)
tree794b21c4ce349a34cd43513d056f6da694cd0b47 /Mk
parent185097c77ab2fddb117276b314768e27f15d4eb8 (diff)
downloadfreebsd-ports-gnome-c74a78b56a0693244bc0e28895aa5aa6fda6cc85.tar.gz
freebsd-ports-gnome-c74a78b56a0693244bc0e28895aa5aa6fda6cc85.tar.zst
freebsd-ports-gnome-c74a78b56a0693244bc0e28895aa5aa6fda6cc85.zip
Start a debug-license target.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.licenses.mk35
1 files changed, 35 insertions, 0 deletions
diff --git a/Mk/bsd.licenses.mk b/Mk/bsd.licenses.mk
index 6c08da5482c6..4f71667e1333 100644
--- a/Mk/bsd.licenses.mk
+++ b/Mk/bsd.licenses.mk
@@ -575,6 +575,36 @@ clean-for-cdrom-list:
IGNORE= License ${_LICENSE} needs confirmation, but BATCH is defined
.endif
+# This should probably be incrementally done while parsing all the license
+# possibilities.
+debug-license: check-license
+.if ${_LICENSE_PERMS:Mdist-mirror}
+ @${ECHO_MSG} "===> License allows mirroring distribution files"
+.else
+ @${ECHO_MSG} "===> License does not allows mirroring distribution files"
+.endif
+.if ${_LICENSE_PERMS:Mdist-sell}
+ @${ECHO_MSG} "===> License allows selling distribution files"
+.else
+ @${ECHO_MSG} "===> License does not allows selling distribution files"
+.endif
+.if ${_LICENSE_PERMS:Mpkg-mirror}
+ @${ECHO_MSG} "===> License allows mirroring pre-built packages"
+.else
+ @${ECHO_MSG} "===> License does not allows selling pre-build packages"
+.endif
+.if ${_LICENSE_PERMS:Mpkg-sell}
+ @${ECHO_MSG} "===> License allows selling pre-build packages"
+.else
+ @${ECHO_MSG} "===> License does not allows selling pre-build packages"
+.endif
+.if ${_LICENSE_PERMS:Mauto-accept}
+ @${ECHO_MSG} "===> License allows being auto-accepted"
+.else
+ @${ECHO_MSG} "===> License does not allows being auto-accepted"
+.endif
+
+
check-license:
.if defined(_LICENSE_ERROR)
@${ECHO_MSG} "===> License not correctly defined: ${_LICENSE_ERROR}"
@@ -772,6 +802,11 @@ install-license:
.else # !LICENSE
+debug-license:
+. if defined(LICENSE_VERBOSE)
+ @${ECHO_MSG} "===> License debug empty, port has not defined LICENSE"
+. endif
+
check-license:
. if defined(LICENSE_VERBOSE)
@${ECHO_MSG} "===> License check disabled, port has not defined LICENSE"