aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-09-21 19:16:08 +0800
committerjbeich <jbeich@FreeBSD.org>2018-09-21 19:16:08 +0800
commitd3cfd07905014382bd672b631d30db478065ae94 (patch)
treee2d812af91ece4a48409ff14888df2f53b646cd2 /Mk
parent568312a7fe0ef45a5a59f8d106f0f60625795dd9 (diff)
downloadfreebsd-ports-gnome-d3cfd07905014382bd672b631d30db478065ae94.tar.gz
freebsd-ports-gnome-d3cfd07905014382bd672b631d30db478065ae94.tar.zst
freebsd-ports-gnome-d3cfd07905014382bd672b631d30db478065ae94.zip
lang/rust: unbundle libgit2/libssh2
- libgit2 in ports is nowadays newer than bundled version - libssh2 was already unbundled until 1.29.0 update - Unbundle libssh2 for USES=cargo (unused atm) PR: 231411 Approved by: rust (dumbbell, tobik)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/cargo.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/Mk/Uses/cargo.mk b/Mk/Uses/cargo.mk
index 30da95f02df6..7590170a069b 100644
--- a/Mk/Uses/cargo.mk
+++ b/Mk/Uses/cargo.mk
@@ -153,6 +153,12 @@ CARGO_ENV+= LIBGIT2_SYS_USE_PKG_CONFIG=1
LIB_DEPENDS+= libgit2.so:devel/libgit2
.endif
+.if ${CARGO_CRATES:Mlibssh2-sys-[0-9]*}
+# Use the system's libssh2 instead of building the bundled version
+CARGO_ENV+= LIBSSH2_SYS_USE_PKG_CONFIG=1
+LIB_DEPENDS+= libssh2.so:security/libssh2
+.endif
+
.if ${CARGO_CRATES:Monig_sys-[0-9]*}
# onig_sys always prefers the system library but will try to link
# statically with it. Since devel/oniguruma doesn't provide a static