aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2017-05-02 13:40:53 +0800
committergerald <gerald@FreeBSD.org>2017-05-02 13:40:53 +0800
commite4be7b455934f99b8d6932b976b36c5e2130f2f6 (patch)
tree08738e33add432f30d9977da48e6d32eaf62719e /Mk
parentb2aa99496811f78484793ed0ffaf0d1bdd796d03 (diff)
downloadfreebsd-ports-gnome-e4be7b455934f99b8d6932b976b36c5e2130f2f6.tar.gz
freebsd-ports-gnome-e4be7b455934f99b8d6932b976b36c5e2130f2f6.tar.zst
freebsd-ports-gnome-e4be7b455934f99b8d6932b976b36c5e2130f2f6.zip
As of today, USE_GCC=yes (and USE_GCC=any in most circumstances)
and consequently many of the USES=compiler flavors use the canonical version of GCC as defined in Mk/bsd.default-versions.mk as well as the lang/gcc port With the "new" setup starting with GCC 5 where I have introduced lang/gcc5-devel for regular snapshots and lang/gcc5 for releases, and similarly for GCC 6 and onward, we can now leverage lang/gcc5 (and later) for most of the role that lang/gcc used to play -- and indeed as of today lang/gcc and lang/gcc5 are nearly identical short of symlinks for gcc, g++, and gfortran binaries that the former provides. So now use lang/gcc5 instead of lang/gcc whenever requested via the USE_GCC framework directly or indirectly. This is similar to how the python ports work, for example, and it allows simplifications in Mk/bsd.gcc.mk and Mk/Uses/fortran.mk and dropping LANG_GCC_IS from Mk/bsd.default-versions.mk. As a next step lang/gcc is going to become a "hull" essentially only providing those symlinks and requiring lang/gcc5 (or whatever has been set as default in Mk/bsd.default-versions.mk).
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/fortran.mk5
-rw-r--r--Mk/bsd.default-versions.mk3
-rw-r--r--Mk/bsd.gcc.mk4
3 files changed, 0 insertions, 12 deletions
diff --git a/Mk/Uses/fortran.mk b/Mk/Uses/fortran.mk
index 9265e1e509ce..2e3fab0322ac 100644
--- a/Mk/Uses/fortran.mk
+++ b/Mk/Uses/fortran.mk
@@ -17,13 +17,8 @@ fortran_ARGS= gcc
.if ${fortran_ARGS} == gcc
_GCC_VER= ${GCC_DEFAULT:S/.//}
-.if ${GCC_DEFAULT} == ${LANG_GCC_IS}
-BUILD_DEPENDS+= gfortran${_GCC_VER}:lang/gcc
-RUN_DEPENDS+= gfortran${_GCC_VER}:lang/gcc
-.else
BUILD_DEPENDS+= gfortran${_GCC_VER}:lang/gcc${_GCC_VER}
RUN_DEPENDS+= gfortran${_GCC_VER}:lang/gcc${_GCC_VER}
-.endif
USE_BINUTILS= yes
F77= gfortran${_GCC_VER}
FC= gfortran${_GCC_VER}
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index 65d22008ff10..ee5e5ee6b3bc 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -140,7 +140,4 @@ TCLTK_DEFAULT?= 8.6
# Possible values: 4, 5
VARNISH_DEFAULT?= 4
-# Version of lang/gcc. Do not override!
-LANG_GCC_IS= 5
-
.endif
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 453fdb9a99a8..08ce6bee0f40 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -144,11 +144,7 @@ _USE_GCC:= ${GCC_DEFAULT}
. if ${OSVERSION} > ${_GCCVERSION_${v}_R} || !exists(/usr/bin/gcc)
V:= ${_GCCVERSION_${v}_V:S/.//}
_GCC_PORT_DEPENDS:= gcc${V}
-. if ${_USE_GCC} == ${LANG_GCC_IS}
-_GCC_PORT:= gcc
-. else
_GCC_PORT:= gcc${V}
-. endif
CC:= gcc${V}
CXX:= g++${V}
CPP:= cpp${V}