aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-09-07 20:43:22 +0800
committertijl <tijl@FreeBSD.org>2016-09-07 20:43:22 +0800
commitead4be38d89ad64cc1ca84c5a754424cbca9bc21 (patch)
treed41bcf410a7fc743b61a34bce3e34230f2282700 /Mk
parentafa8c5c5e676782e1fa3b1cddbc80031fc14f4b3 (diff)
downloadfreebsd-ports-gnome-ead4be38d89ad64cc1ca84c5a754424cbca9bc21.tar.gz
freebsd-ports-gnome-ead4be38d89ad64cc1ca84c5a754424cbca9bc21.tar.zst
freebsd-ports-gnome-ead4be38d89ad64cc1ca84c5a754424cbca9bc21.zip
- In Uses/linux.mk use the loop variable directly when appending to
*_DEPENDS. Helper variables derived from the loop variable aren't expanded causing *_DEPENDS to be incorrect. - Bump all ports with more than one value in USE_LINUX. PR: 211645 Reported by: jkim
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/linux.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/Mk/Uses/linux.mk b/Mk/Uses/linux.mk
index 90f081b6b0fe..24352b3024ae 100644
--- a/Mk/Uses/linux.mk
+++ b/Mk/Uses/linux.mk
@@ -138,16 +138,15 @@ linux_xorglibs_DEP= linux-${linux_ARGS}-xorg-libs>0:x11/linux-${linux_ARGS}-xor
USE_LINUX?= base
.for i in ${USE_LINUX}
-_i:= ${i:C/\:.*//}
-_i_args:= ${i:C/^[^\:]*(\:|\$)//:S/,/ /g}
+_i_args:= ${i:C/^[^:]*:?//:S/,/ /g}
.if ${_i_args:Mpatch}
-PATCH_DEPENDS+= ${linux_${_i}_DEP}
+PATCH_DEPENDS+= ${linux_${i:C/:.*//}_DEP}
.endif
.if ${_i_args:Mbuild}
-BUILD_DEPENDS+= ${linux_${_i}_DEP}
+BUILD_DEPENDS+= ${linux_${i:C/:.*//}_DEP}
.endif
.if ${_i_args:Mrun} || empty(_i_args)
-RUN_DEPENDS+= ${linux_${_i}_DEP}
+RUN_DEPENDS+= ${linux_${i:C/:.*//}_DEP}
.endif
.endfor