aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2014-03-11 04:41:10 +0800
committergerald <gerald@FreeBSD.org>2014-03-11 04:41:10 +0800
commit04c8ad7602e8fd91b79f4579967539bdd850665d (patch)
tree82527306aa3108dfd71eceb51029c5e47d78944a /Mk
parente9f032838d2a0f43f0171aeb5c9adf58f177b755 (diff)
downloadfreebsd-ports-gnome-04c8ad7602e8fd91b79f4579967539bdd850665d.tar.gz
freebsd-ports-gnome-04c8ad7602e8fd91b79f4579967539bdd850665d.tar.zst
freebsd-ports-gnome-04c8ad7602e8fd91b79f4579967539bdd850665d.zip
Update the default version of GCC used in the Ports Collection from
GCC 4.6.4 to GCC 4.7.3. This entails updating the lang/gcc port as well as changing the default in Mk/bsd.default-versions.mk. This adds powerpc64 as a supported architecture (and removes ia64, though it can be supported by manually installing lang/gcc48). New binaries %%GNU_HOST%%-gcc-ar47, %%GNU_HOST%%-gcc-nm47, and %%GNU_HOST%%-gcc-ranlib47 are provided to support link-time optimization (LTO) which scales significantly better. And it adds support for indirect functions (IFUNCS), experimental support for transactional memory in the compiler as well as a supporting run-time library called libitm, a new string length optimization pass, and support for atomic operations specifying the C++11/C11 memory model. Version 3.1 of the OpenMP specification is now supported for the C, C++, and Fortran compilers. GCC accepts the options -std=c11 and -std=gnu11 for the C11 revision of the ISO C standard which inlcude support for unicode strings, nonreturning functions (_Noreturn and <stdnoreturn.h>), alignment support (_Alignas, _Alignof, max_align_t, <stdalign.h>), and a __builtin_complex built-in function. The C++ frontend now accepts the -std=c++11, -std=gnu++11, and -Wc++11-compat options and implements many C++11 features of the language including extended friends syntax, explicit override control, non-static data member initializers, user-defined literals, alias declarations, delegating constructors, atomic classes, and more. The C++ standard library and Fortran frontend have received many improvements. See http://gcc.gnu.org/gcc-4.7/changes.html for an extense list of changes; http://gcc.gnu.org/gcc-4.7/porting_to.html for information on how to port to that new version. PR: 182136 Supported by: Christoph Moench-Tegeder <cmt@burggraben.net> (fixing many ports) Tested by: bdrewery (two -exp runs)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.default-versions.mk2
-rw-r--r--Mk/bsd.gcc.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index 7885423f2032..d1f701fa3fb3 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -20,7 +20,7 @@ ${_l:U}_DEFAULT= ${lang:C/.*=//g}
APACHE_DEFAULT?= 2.2
FPC_DEFAULT?= 2.6.2
-GCC_DEFAULT?= 4.6
+GCC_DEFAULT?= 4.7
LUA_DEFAULT?= 5.2
MYSQL_DEFAULT?= 5.5
PERL5_DEFAULT?= 5.16
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index f8e535b017af..cc158ea5be70 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -19,7 +19,7 @@
#
# Examples:
# USE_GCC= yes # port requires a current version of GCC
-# # (4.6 as of today, subject to change).
+# # (4.7 as of today, subject to change).
# USE_GCC= any # port requires GCC 4.2 or later.
# USE_GCC= 4.8+ # port requires GCC 4.8 or later.
# USE_GCC= 4.8 # port requires GCC 4.8.